1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

I REALLY NEED TO KNOW ASAP

Discussion in 'PS2' started by jaykool, Nov 25, 2003.

  1. jaykool

    jaykool Member

    Joined:
    May 2, 2003
    Messages:
    44
    Likes Received:
    0
    Trophy Points:
    16
    I know this sounds like a question asked a million time but I really need to know once and for all the answer. Will the swap magic ver 2.0 work with the version 7 ps2 and the version 9 ps2. If not, which one will it not work with and what are the issues. I need to know from someone with personal experience if possible. Thank You
     
  2. yoshi9784

    yoshi9784 Guest

Share This Page