1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

I think i bricked my psp

Discussion in 'Sony PSP - Mod and firmware discussion' started by BigBosss, Mar 23, 2007.

  1. BigBosss

    BigBosss Member

    Joined:
    Mar 23, 2007
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    11
    Ok i did the downgrade from 3.0.3 to 1.5 and now when i start my psp it comes on black bu if i unplugthe power cord i can see everything i was gonna upgrade to 3.0.3 oe so should i wait

    Any ideas
     
  2. fultonla

    fultonla Guest

    this may sound stupid but did you try pressing the screen brightness button. cause when I emulate 1.5 when the power cord is plugged in I have to hit the brightness button for everything to show up. just a thought.
     
  3. MidnightJ

    MidnightJ Guest

    Your going to upgrade to 3.03 what? The custom firmware or the Sony one?
     
  4. dadudesam

    dadudesam Member

    Joined:
    Jan 20, 2007
    Messages:
    51
    Likes Received:
    0
    Trophy Points:
    16
    He said "i was gonna upgrade to 3.0.3 oe". Try upgrading then when you startup your psp, hold the power button so it shuts off completely, then when you start it up, hold the R trigger. Hit up, then X (or in other words go to exit) then you'll be at the psp screen again. After that Shut it down by holding the power again. Then start it back up with the power plugged in and see if that fixes it.
     
  5. BigBosss

    BigBosss Member

    Joined:
    Mar 23, 2007
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    11
    I got it to work but i think it could be courrpt my games aren't working
     
  6. kelsirose

    kelsirose Member

    Joined:
    Nov 30, 2006
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    16
    what type of games are you playing isos? Are they in root/iso folder?
     

Share This Page