1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

I want an Emulator for my PSP version 6.39 What Do I Do?

Discussion in 'Sony PSP - Mod and firmware discussion' started by angelmuniz, Jun 23, 2011.

  1. angelmuniz

    angelmuniz Member

    Joined:
    Jun 23, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    11
    SOMEBODY HELP ME
     
  2. Eisherz

    Eisherz Active member

    Joined:
    Nov 28, 2006
    Messages:
    2,832
    Likes Received:
    33
    Trophy Points:
    78
    First of all, give more info. What PSP?
     
  3. tatsuri16

    tatsuri16 Member

    Joined:
    Jun 26, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    11
    I need help on it too, i'm trying to get the daedalusx64 into my psp3000 version 6.39. the daedalus logo shows on the game section, but when i start it, it always says the game cannot be started. The data is corrupted. please help thanks!!
     
  4. brianna1

    brianna1 Member

    Joined:
    Jun 29, 2011
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    11
     
  5. JSPHAT

    JSPHAT Member

    Joined:
    Jun 29, 2011
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    11
    Hey guys it sounds like you have loaded the emulator, which is the program that mimics whatever game system it is, but not the game code itself. Go to any seach engine on your home pc or laptop and search for say Nintendo 64 psp codes. You will find many sites that have thousands of game files to download. Download your file then simply follow the readme instructions that are included in the emulator file. You also must have Modified firmware. Download 6.39 PRO B7, again you can find it very easily by going to a search engine getting the download and following the instructions. This will need a program like winrar to extract the files first. Then place the files on your F: drive while PSP is in USB mode. Should work now. This is the fun stuff guys!
     
  6. brianna1

    brianna1 Member

    Joined:
    Jun 29, 2011
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    11
    okay well i just figued out to downgrade my psp to 6.20 and it stll doing the same thing, im going to the website, psphacks and i do those emulators and it still comes up the same way.......
     
  7. keebles

    keebles Regular member

    Joined:
    Aug 13, 2005
    Messages:
    714
    Likes Received:
    1
    Trophy Points:
    26
  8. Eisherz

    Eisherz Active member

    Joined:
    Nov 28, 2006
    Messages:
    2,832
    Likes Received:
    33
    Trophy Points:
    78
    I didn't want to answer here anymore, because that is basic stuff. But seriously, who still uses HBL? For those with PSP 3000 use the latest PRO version for your firmware ( 6.20 PRO-B7 for example), for those with PSP 1000 or 2000 (hackable version) get 6.39 MEv7.
     
  9. keebles

    keebles Regular member

    Joined:
    Aug 13, 2005
    Messages:
    714
    Likes Received:
    1
    Trophy Points:
    26
    I dont want to use modded firmware because I am not comfortable installing it. nor can I make a Pandora battery to rescue it if it fails.
     

Share This Page