1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Inerlace Question

Discussion in 'Video capturing from analog sources' started by MauriceB, Jun 4, 2004.

  1. MauriceB

    MauriceB Member

    Joined:
    Mar 31, 2004
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    11
    I have authored several DVD’s with menus, etc., but my 8mm analog video quality suffers from an interlace problem. The captured AVI video is deteriorated and one can see horizontal lines around the edges of objects when viewing, especially after conversion to mpeg.

    I’m convinced I have a interlacing problem. How do I fix this? I have tried everything I can think of. I have given my videotape to another person who captured it fine. I took his same portable unit (firewire) and used it on my computer but it still creates the lines.

    Since I have this problem, what or how do I tell a program to fix it by deinterlacing, assuming that is what I need to do?

    I use Studio 8, TMPGnc DVD, TMPGnc, Virtual Dub, etc. Thank you.
     
  2. Praetor

    Praetor Moderator Staff Member

    Joined:
    Jun 4, 2003
    Messages:
    6,927
    Likes Received:
    1
    Trophy Points:
    116
    Did you pass the AVI through a Deinterlace filter in virtualdub? :)
     
  3. MauriceB

    MauriceB Member

    Joined:
    Mar 31, 2004
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    11
    It's been a while and I can't remember but my guess is no, as I probably didn't know where to find it. Can you provide some direction? Thanks.
     
  4. MauriceB

    MauriceB Member

    Joined:
    Mar 31, 2004
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    11
    I will try to explain my process of capturing:
    I connect my 8mm analog camera to my AIW 9700 card by RCA cables. The cables run from my camera to the cord and connector that is attached to the back of my video card. I then usually use Studio 8 to capture as AVI. I have used VirtualDub, TMPGE, and 2-3 other programs with the same exact results. I then edit in Studio 8, and have used Studio 8 and other programs to create menus, and burn a mpeg either to my hard disk or DVD. All produce the same poor video.

    I believe the problem is in capturing. I gave my 8mm tape to my friend to capture. He used his portable capture device and firewire connection to capture in Studio 8 (AVI). I can view his captured AVI file on my computer and not see the problem as I have already posted in the photo on this page. I have used his capture device (firewire) to capture the same video but have same problem. He tells me the firewire bypasses my video card and thus eliminates it as a possible problem. I don’t know what else there is to check unless my video camera itself (not tape) is the problem. However, I have hooked up a VCR to capture but can’t remember the results as being good.

    I really don’t know what else to do. Thanks for your help.
     
  5. Minion

    Minion Senior member

    Joined:
    Sep 28, 2003
    Messages:
    5,768
    Likes Received:
    0
    Trophy Points:
    116
    To get rid of Interlaceing Artifacts you must use a deinterlace filter...Your encoder should have one as all of the Good encoders have an option to de-interlace while encodeing and if your doesn"t have one I suggest you switch to one that does....
    Tmpgenc has 16 different Deinterlace Filters in the "Advanced Settings" and the MainConcept Encoder has a couple of Basic De-interlace filters that work well also....
    I personally use a the Smart Bob De-interlace filter Plugin for AVISynth and it works very well but AVISynth is a bit advanced for most poeple......

    Cheers
     
  6. MauriceB

    MauriceB Member

    Joined:
    Mar 31, 2004
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    11
    Isn't TMPGE for encoding an existing digital file? I think the problem is in the actual capture process from my video camera to AVI as that file is of poor quality with horizontal black lines around objects. Thanks.
     
  7. Minion

    Minion Senior member

    Joined:
    Sep 28, 2003
    Messages:
    5,768
    Likes Received:
    0
    Trophy Points:
    116
    Tmpgenc is For Encodeing AVI files to Mpeg2 which is the Format you use for Authoring DVD"s....
    It has a choice of 16 different Deinterlace filters in it"s advanced settings which will de-interlace the Footage to get rid of any Interlaceing Lines...
    If the Lines you are talking about are Not Interlace lines then the deinterlace filter will not get rid of them and there is probably nothing you can do about it because the lines are probably part of the Video...

    So you Just use Tmpgenc to encode your AVI file to Mpeg2/DVD with the De-Interlace filter on and then after encodeing you Just import the Mpeg2 file into your DVD authoring Program to add your Menu"s and Chapters and to burn the final DVD....
    Useing Studio 8 to encode your AVI file to Mpeg2/DVD is a Bad Idea because it uses a crappy encoder and will not produce very good results.....

    Cheers
     
  8. Nilis

    Nilis Member

    Joined:
    Jun 3, 2004
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    11
    Talking about the de-interlace filter wat works best: even, odd, double, even+odd?
     
  9. Minion

    Minion Senior member

    Joined:
    Sep 28, 2003
    Messages:
    5,768
    Likes Received:
    0
    Trophy Points:
    116
    Well you use the One that looks Best in the window in the Deinterlace filter settings...
    I generally get the best results useing the "Double Field" filter because it is a field Blending filter were the other one either Just use the Top or Bottom fields....
    Moove the Slider under the Window in the Deinterlace filter window to a spot were you can really see the lines Badly and then try each one of the filters and see which one makes the Picture look best, Just make sure you have the "Enable filter" box checked.....

    Cheers
     
  10. MauriceB

    MauriceB Member

    Joined:
    Mar 31, 2004
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    11
    One always gets deeper and deeper trying to help someone. I aplolgize but I don't see the 16 filters in the advanced setting of TMPGE. I count 11 in the window with a check box by each one. I don't see the double. ??
     
  11. Minion

    Minion Senior member

    Joined:
    Sep 28, 2003
    Messages:
    5,768
    Likes Received:
    0
    Trophy Points:
    116
    To find the De-interlace Filters you Look at the List of 11 filters and double click the "De-Interlace" filter and a New Window will pop up with your File displayed in the Window and a Dropdown menu with about 16 different De-Interlace filters but the only ones that really are any good are the Odd field the even field and the Double Field filters but use whatever one looks best in the window....Cheers

    PS: You should NOT enable all 11 filters in the Advanced settings only the Ones that you are going to use because each Filter will Increase the Time it takes to encode and you don"t need to use them all especially when you probably don"t know what they all do......
     
  12. MauriceB

    MauriceB Member

    Joined:
    Mar 31, 2004
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    11
    Minion, Thank you. I guess I can't read the box where it says to double click. Using the double did remove all the lines. I will have to play with it see which is best but I appreciate your telling me this. This is the first time I think it migth actually work.

    So I guess I capture as AVI and then use TMPGE to render to mpeg. What about editing and special effects. Is it best to edit the AVI then use TMPGE?
     
  13. Minion

    Minion Senior member

    Joined:
    Sep 28, 2003
    Messages:
    5,768
    Likes Received:
    0
    Trophy Points:
    116
    If you have to do any editing useing effects and Transitions then it is probably best to do the editing when the file is in AVI format but make sure you render your edited file to AVI useing a Low compression AVI codec like HuffYUV because rendering to a highly compressed Codec will degrade the quality.....
    If you had a Good High end Video editor Like Vegas Video 5 or Adobe Premier Pro then you could use them to Render your Project directly to mpeg because they use better quality encoders than Cheaper editors and they can also deinterlace and add complex transitions and effects......
    Mpeg files aren"t made to be edited and Most editors will re-encode the Mpeg file when editing which ruins the quality but there are a couple editors which are made especially for editing Mpeg files and these editors do not degrade the quality....
    There are only 2 editors like this that I know of and they are "Womble Mpeg2VCR" and "Womble Mpeg video Wizard".......

    Cheers
     
  14. MauriceB

    MauriceB Member

    Joined:
    Mar 31, 2004
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    11
    Okay, thanks. I figured I must do it in AVI so I don't degrade the video. I think you are saying that once I do all my editing using the original AVI file, render it, keeping it in AVI format, using low compression. Then use TMPGE.

    Do you know of a free program that will render using HuffYUV codec? Studio 8 won't display the codec. Will VirtualDub do it, I can't remember?

    Wish I had the money for Vegas.
     
  15. drcl

    drcl Member

    Joined:
    Jun 6, 2004
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    11
    everybody is wrong!

    DO NOT DE-INTERLACE IF YOU ARE GOING TO PLAYBACK ON DVD PLAYER!

    TMPGENC can encode as interlaced.

    Set the source to interlace and the encoding mode to interlaced. If you are using a new version it will automatically detect the field order for you.

    if you have an old version and cant auto detect field order do a short sample and either it on a DVD-+RW or a software player. I don't recommend powerDVD. It plays back wrong sometimes. MediaPlayerClassic is best.

    Why not deinterlace you say?

    Should all TV programmes be deinterlaced? I think not.
    an 8mm camera outputs just like a VCR does to a TV a VCR doesn't have any deinterlacer.

    if you deinterlace you will make the picture half as smooth and loose half the resolution - if you use any of TMPGs deinterlacers. You may as well capture at half height in the first place and then resize to full height!

    if you are hell bent on deinterlacing use an area based deinterlacer or a smart bob. You will get a film like efect but retain the detail.

    if you want do do proper editing on a budget learn to use avisynth.

    capturing with huffyuv should work with any software. do you have your capture card set to yuy2 or rgb24? if no then thats why it wont show up in the VCM list.

    afterthought... do you have huffyuv installed?


     
  16. sspring

    sspring Member

    Joined:
    May 29, 2003
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    11
    This site will explain all www.100fps.com
     
  17. MauriceB

    MauriceB Member

    Joined:
    Mar 31, 2004
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    11
    drcl, Yes, I have the huffyuv installed. It appears in some programs but not in Studio 8.

    I plan on capturing a little more video and running the double filter to see what happens on TV. All I know is that I have this curse of black horizontal lines around images and this double filter removed them. What it does to the image as seen on TV may be another matter as I have not tried it yet.

    As far as having my capture card set to yuy2 or rgb24, I don't know as I don't think I ever did nor do I know where to check. Thanks.
     
  18. Minion

    Minion Senior member

    Joined:
    Sep 28, 2003
    Messages:
    5,768
    Likes Received:
    0
    Trophy Points:
    116
    His Problem is that there are Interlace Artifacts while Watching on his DVD Player so there is Now way to Remove those artifacts Unless you De-Interlace...
    Unless you know a way of Removeing artifacts without De-Interlaceing....

    Generally you should never De-interlace But if you are Experienceing Field Jumping and other Artifacts that reverceing the Field order does not Fix then you Must deinterlace to get rid of the artifacts....

    PS: Not all de-Interlacers Make you Loose Half the Resolution or loose half the Video
    Information...Only the Ones that remove a field to get rid of the Artifacts do that, If you use a field Blending or an Adaptive de-interlacer then you do not loose Half the Video Information because they do not remove Fields .....
    _X_X_X_X_X_[small]It"s better to be Pissed Off than Pissed On!!![/small]
     
    Last edited: Jun 7, 2004
  19. MauriceB

    MauriceB Member

    Joined:
    Mar 31, 2004
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    11
    Thanks for the input. I just wish I knew why it is doing it in the first place.

    Does anyone know if a capture device connected to the PC via firewire actually bypasses the video card? If it doesn't then maybe that's where the problem lies. I think I have elimnated everything else except the motherboard. It's not the tape, or camcorder.
     
  20. drcl

    drcl Member

    Joined:
    Jun 6, 2004
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    11
    @mauriceb

    are you capturing at full height or capturing at an arbitary height. you should capture at pal576/ntsc480

    if you are not and then resizing without respect to separating the fields first then you will get very hard to remove artifacts. Which video arrange/image positioning method are you using in TMPGenc? this could be your problem

    you say the artifacts are black.. are there no other colours affected? if this is so then it looks like a problem with the camera or possibly the capture device.
    if they were true interlace problem you should be able to remove them with any bog standard deinterlacer.

    After reading your post more closely I think it is most likely your camerais buggered; try connecting it to your tv - you will need to look closely as your capture card is probably more sensitive than your TV. I think I had this exact same problem with an old vhs vcr.

    another afterthought... what about your capture card settings. I'm not familiar with your card but if it has black level coring activated you may get a problem like this.

    can you send me a still or a very short clip avi (56k modem) with no processing. drcl_"AT"tiscali.co.uk

    replace the "AT" with @
     

Share This Page