1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

INTERNAL ERROR: You're a Newbie!!

Discussion in 'DVD±R for advanced users' started by FoxFlame, Feb 3, 2004.

  1. FoxFlame

    FoxFlame Member

    Joined:
    Feb 3, 2004
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    11
    I put this in the newbie forum, but after reviewing it, I realized it might not be so much of a "newbie" question? As a professional technician I'd like to think of myself as a bit more advanced, but after attempting to research this error elsewhere, I can find no evidence of it online:

    Since I like to learn the hard way, I decided the best way to learn all about DVD-Authoring would be to take a DVD9 I own, rip it to my hard drive, convert it to AVI, Strip the AC3 stream, Reencode it to m2v, and then attempt to author it with IFPedit while adding the AC3 stream back in, then burn it to a DVD5. As I said, I like doing things the hard way.

    On the plus side, I've learned a lot in the last three days. On the down side, I'm stuck with a copy of Shrek, that looks fantastic on my DVD5, but I only get crystal clear audio for the first 20 seconds or so (through the Dreamworks credits, and right after it starts to give the production studio credits, then it cuts out). Now, the only actual error I've run into during this entire process was during the IFOedit when it said "INTERNAL ERROR: available data blah blah something not enough input buffer" (I can get an exact quote soon if necessary, both PCs are doing something) that happens VERY EARLY ON during the...transmodification...super duper....oh right, Muxing process (I think that's it, I told you, I *am* learning!) which would explain why the audio only works for such a short period of time into the movie. Needless to say, it went ahead and continued creating the VOB files, and I've since learned to view the VOBs on the hard drive before burning them to see if they're ok.

    I'm currently running AutoGK again on the ripped VOBs, and this time I selected the AC3 stream only, instead of Auto (AC3/VBR MP3) and the server I burn DVDs on is currently trying to use DVD X Copy XPRESS to burn it to DVD too (I like to cover all my bases). Hopefully, the new AVI will have a correct AC3 that I can strip out of it to be added back in the IFOedit, but I have a feeling the AC3 file I currently have is just fine and something is going wrong with the muxing process in IFOedit...

    Has anyone encountered this error with IFO? Is there a program available (freeware) that will enable me to play an AC3 file to see if I even pulled it out correctly?

    Thanks in advance,
    --Fox

    I'll try to post the exact error when DVD X COPY finishes.
     
  2. FoxFlame

    FoxFlame Member

    Joined:
    Feb 3, 2004
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    11
    Ah crud! I just read the rules (didn't see them at the BOTTOM of the pinned threads), how do I delete my other post? :(
     
  3. FoxFlame

    FoxFlame Member

    Joined:
    Feb 3, 2004
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    11
    INTERNAL ERROR: additional data required but no free space in input buffer
     
  4. fasfrank

    fasfrank Active member

    Joined:
    Oct 15, 2003
    Messages:
    4,117
    Likes Received:
    0
    Trophy Points:
    66
    Well hey at least you read the rules! :D
    Im impressed by anyone who can get ifoedit to do anything. I'm not so sure thats the best way to learn authoring but I say go for it!
    I'm not sure why you converted your DVD files to AVI other than to make things more difficult and interesting.

    Heres something from Doom9:

    9# Q: INTERNAL ERROR: Additional data required but no
    free space in input buffer. ?

    A: You probably used TmpegEnc to produce the video stream and forgot to set the options on the 'GOP structure'-tab:
    - 'Output interval of sequence header'
    - 'MAX number of frames in a GOP'

    You must set the output interval to '1' instead of '0',
    and for the MAX number of frames specify 15 for PAL and 12 for NTSC.

    Fyi:
    http://forum.doom9.org/showthread.php?s=4ce916a573c933bed5dc3c7bc06e6c20&threadid=18817

    http://forum.doom9.org/showthread.php?s=4ce916a573c933bed5dc3c7bc06e6c20&threadid=27441

    _X_X_X_X_X_[small]motorcycle racer
    computer newbie
    Sony VAIO
    Suzuki GSXR1000[/small]
     
    Last edited: Feb 3, 2004
  5. FoxFlame

    FoxFlame Member

    Joined:
    Feb 3, 2004
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    11
    Oh no! That was the thing that took forever! So of course that's what's going to mess up. :p OK, I'll try that next. I'll let you know if it worked in another three days! ^_^

    Thanks for the help!
    --Fox
     
    Last edited: Feb 4, 2004
  6. FoxFlame

    FoxFlame Member

    Joined:
    Feb 3, 2004
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    11
    Erm, Hmm. GOP was set to 1 last time I encoded, but the MAX was 18. I've reset it to 12 after unlocking it, and have begun the reencoding process again. I'll let ya know how it turns out (only did the 6 hour version this time instead of the super high quality 2-pass type!) Mention of this GOP setting would be helpful in the afterdawn guide for avi -> DVD5.
     
  7. FoxFlame

    FoxFlame Member

    Joined:
    Feb 3, 2004
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    11
    *Emits Charlie Brown AAAAUUUURGH!*

    Still no luck. I feel I should mention, the sound cuts out as the production credits begin to roll in the early part of the movie. The production credits are completely whack. They seem to roll 3 or 4 different credits, but in about 5 languages each, for a total of 15-20 flashes of credits. I believe the sound cuts out after the first switch to another language. I'm willing to wager if I could figure out how to make this not occur, and then did the process again, I could get it to work properly. Again, having not found this information anywhere online, I defer to your advice.

    --Fox
     

Share This Page