1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

is my PSP bricked?

Discussion in 'Sony PSP - Mod and firmware discussion' started by drjimmy69, Jan 29, 2012.

  1. drjimmy69

    drjimmy69 Member

    Joined:
    Jan 29, 2012
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    11
    Hi Guys,

    I have a PSP-1003, tried to turn it on and nothing happened, the power light came on and then off after about 15 secs, I looked up my issue and it sounded like it was bricked so I puchased a pandora battery and made a magic memory stick. I sellected INSTALL 5.00 M33. Everything did what it was suppose to do (Flashing Files, Restoring registry etc.) at the INSTALL IS COMPLETE screen I sellected shutdown. took out the MMS + Pandora and inserted my regular battery. Again the power light comes on but nothing else only this time the power remains on until I switch it off.

    After trying this a few times I moved on to another method, I can access the M33 Recovery Menu so I used another Memory card and installed Recovery Flasher v1.65 by HELLCAT. This program also seems to be working fine, I select INSTALL CFW (of version selected above) which is 5.00. I then select reset (format) settings as well and it does its thing. It ends with "all done Press any button to shutdown" the green light flashes for proberbly 10secs and then shuts down. I then turn it back on and it does the same again, power light stays on but nothing else.

    Sorry this is so long winded I just wanted to make sure I include all the details. I basiclly want to know if there is anything else I can try? or am I doing something wrong?

    Cheers Guys
    the doc!
     
  2. pspwxp

    pspwxp Regular member

    Joined:
    May 31, 2008
    Messages:
    196
    Likes Received:
    0
    Trophy Points:
    26
    Use your Pandora to install M33

    Use HellCat to install PRO

    Thats all I really remember from the Pandora method(s)
     
  3. soohenry

    soohenry Member

    Joined:
    Apr 23, 2012
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    11
    Hi, it may be hardware issue as i have repair many such sets. i can be contacted at 97207217, dyno
     

Share This Page