1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Just updated my psp, now trying to play PSX and cant

Discussion in 'Sony PSP - Mod and firmware discussion' started by lazytitan, May 2, 2011.

  1. lazytitan

    lazytitan Regular member

    Joined:
    Nov 7, 2004
    Messages:
    278
    Likes Received:
    0
    Trophy Points:
    26
    My psp is at CFW 5.00 M33-6 and just ran that Prometheus-3 and im able to run every game i have tried so working great.

    Now i have never tried running a psx game before but when i try now says "The system software of your PSP system is version 5.00. To start you must update to version 5.50 or later."

    Do i up to upgrade something or am i doing something wrong. Was looking at something on youtube that just said to put the ebootfile and key bin file in the psp/game directory but getting this error so not sure what im doing wrong or if i have to update but though updating would make it so cant play these newer games.

    EDIT: ok so seem most games i have tried works but FF7 is only one giving me that message. Any ideas why other games work just fine but FF7 is saying i need to update?
     
    Last edited: May 2, 2011
  2. reonlasbard

    reonlasbard Member

    Joined:
    Jul 12, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    11
    did you figure out how to make psx games work on prometheus 3 ? I can't seem to find Jack in google -_- I read the same Eboot+ key stuff, but for some reason it doesn't work.
     

Share This Page