1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Keyboard keys a little messed up?

Discussion in 'PC hardware help' started by sandisk, Mar 18, 2007.

  1. sandisk

    sandisk Regular member

    Joined:
    Jun 27, 2005
    Messages:
    733
    Likes Received:
    0
    Trophy Points:
    26
    Hi guy's. I re-formatted my pc yesterday and now my keyboard is a little messed up.

    Basically if I'm writing an email address and hit the "@" I have to hit no 2 instead holding shift to get the @

    Basically the keys are reversed. I hit " if I really want to hit @

    Not a big deal but it's pis*in me off bigtime lol

    Can this be fixed or keyboard or windows knackered ?

    Thanks
    Sandisk
     
  2. 3lement

    3lement Regular member

    Joined:
    Mar 26, 2007
    Messages:
    326
    Likes Received:
    0
    Trophy Points:
    26
    see if your keyboard is functioning properly (control panel) if it is then you probably have to buy another keyboard. if its not try messing around with it. your probably gonna have to buy a new keyboard. how old is it?
     
  3. ddp

    ddp Moderator Staff Member

    Joined:
    Oct 15, 2004
    Messages:
    39,011
    Likes Received:
    77
    Trophy Points:
    128
    try the keyboard on another computer to see if problem follows it or not. also try another keyboard on computer to see if problem still present as might be a motherboard problem if old keyboard works on other computer ok but not new keyboard.
     
  4. sandisk

    sandisk Regular member

    Joined:
    Jun 27, 2005
    Messages:
    733
    Likes Received:
    0
    Trophy Points:
    26
    Hi and thanks for the replys on this.

    Secondly, my apologies to the guys that replied and afterdawners as I did find the solution to this but "forgot" to post it. Usually I post either way as the answer might help out other people in the future. Sorry bout that.

    As you know, I formatted the pc and the keyboard seemed a little haywire.

    In the end it was a handy enough answer but when you don't know it, it's a pain in the ass.

    Turns out it was the "Regional Settings" that was not right.

    Double click "Control Panel", double click "Regional Settings" and select what country your from and what keyboard you'd like to use. In my case I selected Ireland and an Irish-English Keyboard and all my settings were right again.

    Thanks for the help and replys on this.

    Sandisk
     
    Last edited: Mar 31, 2007

Share This Page