1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

lite on 1633s

Discussion in 'DVD / Blu-ray drives' started by burnerguy, Dec 31, 2004.

  1. burnerguy

    burnerguy Guest

    can someone please help i just got a burner from newegg.com its the lite on 1633s i received it yesterday. i tried burning several dvd's to no avail, i did some checking around and kept seeing upgrade firmware as the solution. i went to their website and downloaded the bsor firmware and flashed it.i realized as it started flashing the drive that i had my grand theft auto ps2 game in the drive. doh.after the flash was complete the drive show it was full with no disc , somehow the gtasa data had been put onto the burner drive. i decided to reflash with the disc out, and did so.after that the drive appeared normal, still played dvd's the gtasa data was now off the drive. i stumbled across a different firmware said to be for my burner drive it is bsos i dont know why but i tried flashing my drive with the bsos firmware and it succeeded. i called lite-on tech support tried everything they told me but to no avail. i tried going back to the bsor firmware but i cant go backwards in firmware. im told that the bsos isnt even for my particular drive and so my burner wont work. ive read these forums and havent really seen anything to answer my problem. if someone out there has an answer please tell me what to do
     
  2. kchev

    kchev Regular member

    Joined:
    Nov 3, 2004
    Messages:
    455
    Likes Received:
    0
    Trophy Points:
    26
    bsos is the newest firmware available for the 1633s
    i have it flashed to mine right now and have no problems
    what media are you using?
    what burning program are you using?
    specifically what is the error and explain more of problem
     
  3. burnerguy

    burnerguy Guest

    i had an i/o error, i tried burning 10 dvd's and none of them made it pat the write in. thats what iniatially prompted me to change my firmware. heres ho i know the flash was bad, when i go into my computer the dvd burner drive the details show up as the drive being a cd rom,which its not. if i right click on my computer and go to manage computer then removable drives, the burner drive letter i select check properties and for the manufacturer it says this device is a cd rom , lite on says i should try to return the drive to newegg and say it came doa. i paid for overnight delivery. but now id have to send it back and wait, i dont know yet, newegg is closed for holidays so i havent talked to them yet.
     
  4. kchev

    kchev Regular member

    Joined:
    Nov 3, 2004
    Messages:
    455
    Likes Received:
    0
    Trophy Points:
    26
    http://club.cdfreaks.com/showthread.php?t=97590

    look here. there is a tool called an omnipatcher made by these guys
    i use it on mine and it will let you flash backwards or however you want to. it works very good because i flashed mine backwards also with it
    here is the page with the firmwares for it
    http://codeguys.rpc1.org/firmwares.html
    download the bsok firmware from their website and try flashing it with that (the stock BSOK under 1633)
    it is the file with BSOC/BSOG/BSOH/BSOK/BSOR-stock-unscrambled (old)
     
    Last edited: Jan 2, 2005
  5. burnerguy

    burnerguy Guest

    thanx ill try that if newegg wont give me new one , truth is ima kinda scared to flash the drive again.
     
  6. burnerguy

    burnerguy Guest

    ok now im sending the burner back was wondering for the new 1633s they send me will there be any necessary firmware updates,from the factory . that ill have to install to get the burner to function?
     
  7. kchev

    kchev Regular member

    Joined:
    Nov 3, 2004
    Messages:
    455
    Likes Received:
    0
    Trophy Points:
    26
    probably, but you don't have to update if you don't want to and you are not having problems with it
     
  8. burnerguy

    burnerguy Guest

    thanx chev i appreciate the help. once i get the burner ill probably post under this thread again if i have any more questions. you sir have a great day, lol im just so happy newegg is replacing the burner.
     
  9. kchev

    kchev Regular member

    Joined:
    Nov 3, 2004
    Messages:
    455
    Likes Received:
    0
    Trophy Points:
    26
    no problem and good luck with the new one
     
  10. burnerguy

    burnerguy Guest

    does anyone know the best media to use for 1633s with stock firmware?
     
  11. bizzle93

    bizzle93 Member

    Joined:
    Sep 10, 2004
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    16
  12. kchev

    kchev Regular member

    Joined:
    Nov 3, 2004
    Messages:
    455
    Likes Received:
    0
    Trophy Points:
    26
  13. Dynochem

    Dynochem Member

    Joined:
    Sep 2, 2004
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    11
    Ihad ALL of your problems and was set to RMA the damn thing back to Ebuyer.
    However, the new BS41 firmware update SHOULD solve most of your bad burns.
    I downloaded EASY MEDIA CREATOR 7 as Nero wouldn't do anything with this drive.
    I can now burn Datasafe Grey top DVDs at 12x instead of 8x... perfect copies
    Also Datasafe Yellow 2.4 at 8x and Infiniti White top at 8x

    I then went and got the latest update to NERO RELOADED 6.6 (I think its 6.6.0.3) and it burns the Datasafe Grey tops at 12x too.

    I had the same probs with an NEC 3500 which I sent back for this one.
    I think they rushed out the 16xD/L drives for Xmas market and now they're updating the firmware to fix all the bugs (mostly not liking certain types of media)
    Also the updates to NERO and EASY MC7 are reflecting changes to do with Dual layer drives & recognising more types of media.
    If you can't find the BS41 firmware (it's the Official version) email me & I'll send it.
    alan.millar@virgin.net
    Hope this helps.
    PS the update also got rid of an annoying high pitched whine it used to make while at top speed
     
  14. burnerguy

    burnerguy Guest

    how come that bs41 isnt on the website for lite on? i could definately use it. also now im stuck with a 25 spindle of memorex dvd+r and a spindle of this hypermedia dvd-r crap.
     
  15. Dynochem

    Dynochem Member

    Joined:
    Sep 2, 2004
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    11
    OK... I went back to the Lite-On sites to check & sure enough the BS41 ain't posted anymore, they used to have a link to the 'codeguys' site and recommended flashing the BS41 firmware with the omnipatch utility provided there.
    Here's the link for the omnipatch utility I used to patch my 1633.
    http://codeguys.rpc1.org/patchers.html
    and here's the link for the bs41 firmware...
    http://codeguys.rpc1.org/firmwares.html
    There are 2 versions of the BS41 to choose from... I used the 'BS41 - stock - unscrambled' version (this was the original one from Lite-On
    The omnipatch utility lets you customise how fast the burn will be for different types of media, and allows you to re-flash back to earlier firmware (although I can't imagine why anyone would want to do that)
    Anyway, this is the combination of patcher & firmware that converted my 1633s from a piece of useless junk into a cracking burner.
    Hope it helps.
     
  16. burnerguy

    burnerguy Guest

    thanx buddy youve been very helpful
     
  17. jcc82

    jcc82 Member

    Joined:
    Jan 13, 2005
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    11
    anybody have problems with dvd playback on the 1633. my drive pauses every 3-4 seconds...causing the movie to pause as well.
     
  18. burnerguy

    burnerguy Guest

    nope my new drive works great and came with bsok firmware.
     
  19. Incosol

    Incosol Member

    Joined:
    Mar 7, 2003
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    11
    Was wondering if anyone can help. Used my 1633S with great success in a Fujitsu Siemens 2.4 Pentium and have now moved it to a Dell 2.6 Celereon. Its performance has slowed marked. It takes about 3 -4 times as long as it did before to copy a DVD using DVD Shrink or to write a new disk (same media as before). It is taking 40 mins+ to write a full DVD at 4x speed.

    Is this simply a processor issue or could it be something else ?

    Should perhaps add that in the Fujitsu I was using slave/master setting with the orignal CD drive as slave and the 1633 as master. In the Dell, as instructed in the Dell manual, I have it set to "cable select" and I assume that the orignal Dell CD drive is set likewise. Is that a problem ?
     
    Last edited: Jan 21, 2005
  20. kchev

    kchev Regular member

    Joined:
    Nov 3, 2004
    Messages:
    455
    Likes Received:
    0
    Trophy Points:
    26
    is DMA enabled?
     

Share This Page