1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

looking for a flip top cover

Discussion in 'PS2 - Hardware boot discussion' started by showan, Dec 2, 2004.

  1. showan

    showan Regular member

    Joined:
    Sep 19, 2004
    Messages:
    168
    Likes Received:
    0
    Trophy Points:
    26
    i've recently been looking for a ps2 flip top cover. I've looked on some websites and notice that they say you need to have a flip top that's compatible with the version of ps2. Why does the version of the ps2 matter?

    also, anyone know why there are different versions of the swap magic boot disc? I have v3.3. i have seen 3.2, 3.0, 2.0, etc. Why do they keep updating it?
     
  2. BirdeX

    BirdeX Member

    Joined:
    Oct 31, 2004
    Messages:
    59
    Likes Received:
    0
    Trophy Points:
    16
    The version matter because there are only 8 screws in the new ps2 to open it like V9 and V10. But there are 10 screws in older systems. For e.x. If you have a V4
    PS2 and you buy a V9 Fliptop it wont feet on your ps2 because your ps2 hase 10 screws and the fliptop has 8.
    The Swap magic 3.3 is the newest. It works with all version PS2. Like 3.2 or less, it wont work on the new systems only the old once. New versions come out, then they update it so people can buy it for there Console.
     

Share This Page