1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Lossless AVI to Mpeg 2 Issues

Discussion in 'MPEG-1 and MPEG-2 encoding (AVI to DVD)' started by madrabbit, Apr 10, 2005.

  1. madrabbit

    madrabbit Member

    Joined:
    Jan 19, 2003
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    11
    My TV capture software (WinDVR) can automatically capture to SVCD format, the quality is good, but I thought I could do better since it's mpeg configuration is limited...

    I have captured video in lossless avi format at a resolution of 640x480, 29.97fps (NTSC). I am attempting to convert this to SVCD using TMPGEnc Plus at a bitrate of 2520. The problem is that the resulting quality is horrible, and nowhere near what I get with WinDVR at the same bitrate. I've experimented with the interlace settings as well as the deinterlace filters, but that doesn't seem to make a difference. It's probably not even related to the problem of the large "blocks" that appear throughout the picture.

    What could be the problem?

     
  2. aldaco12

    aldaco12 Active member

    Joined:
    Nov 6, 2002
    Messages:
    2,544
    Likes Received:
    0
    Trophy Points:
    66
    Strange. A 2520 kbps SVCD should be good. If the TMPGenc's settings were good ('motion search precision = highest quality (very slow)' , maybe it's only an AVI extraction bad failure. Which cidec, and which settings for that codec did you use? How many kbps had your codec? Since that AVI will only temporary, it can be even huge (like a DVD-movie; Xvid bitrate = max) because all will shrink to a 2*830 MB movie (I prefer to use FitCD to get 2 CDs for < 110' movies only, rather 3 CDs for all movies, and make 2 CD-VCDs for longer [>110'] ones ) after the TMPgenc setting desctibed in http://www.afterdawn.com/guides/archive/dvd2svcd_with_tmpgenc.cfm .
     
    Last edited: Apr 11, 2005
  3. madrabbit

    madrabbit Member

    Joined:
    Jan 19, 2003
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    11
    I used iuVCR and Huffyuf 2.1.1 at its highest settings for the capture. I've also tried using "No Compression" which of course has no settings.

    I'm thinking it must be a problem with my captured avi because when I use the same TMPGEnc SVCD profile with a high quality downloaded avi, such as Divx, the resulting mpg looks very good.
     
  4. aldaco12

    aldaco12 Active member

    Joined:
    Nov 6, 2002
    Messages:
    2,544
    Likes Received:
    0
    Trophy Points:
    66
    If you want to make a comparison, simply load the input AVI with your PC's player and compare it with the final mepg-2 (I hope your PC doesn't give you any trouble in viewing SVCD movies. Mine, apart the impossibility to show and to modify the point of movie [e.g. 00:10:05 ; it's fixed at 00:00:00 ] I'm watching, doesn't.)
    This is a rather raw check, but it might help you finding where the 'real' problem lies.
     
  5. rebootjim

    rebootjim Active member

    Joined:
    May 13, 2004
    Messages:
    2,631
    Likes Received:
    0
    Trophy Points:
    66
    The problem lies in your capture aspect, and the encoder must resize.
    If you capture at 480x480 with huffyuv, then encode, the conversion is only to mpeg-2, and the encoder doesn't have to resize anything.
     
  6. madrabbit

    madrabbit Member

    Joined:
    Jan 19, 2003
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    11
    Thanks for the tip. I thought that reducing the size during encoding might actually improve the quality. But since it didn't, I'm obviously wrong about that.

    I'll try 480x480 and see what happens.
     
  7. madrabbit

    madrabbit Member

    Joined:
    Jan 19, 2003
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    11
    I captured the lossless avi to 480x480. Same result. The quality after encoding is so bad, it's not watchable.

    I encoded a download Divx avi using the same TMPGEnc profile, just for comparison. It looks beautiful.

    I'm stumped
     
    Last edited: Apr 12, 2005
  8. rebootjim

    rebootjim Active member

    Joined:
    May 13, 2004
    Messages:
    2,631
    Likes Received:
    0
    Trophy Points:
    66
    What's the bitrate of your original capture?
    Macroblocking is usually a result of insufficient bitrate.
    When you say "lossless avi format", what codec are you using, if any?
    What colourspace are you using?
     
  9. madrabbit

    madrabbit Member

    Joined:
    Jan 19, 2003
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    11
    I'm using the Huffyuf 2.1.1 codec for lossless avi. I've also used the "no compression" option. Neither offer a setting for bitrate.

    The only settings I can control are Color Format which is set to YUY2, the framerate set at 29.97, and of course the capture size.



     
  10. aldaco12

    aldaco12 Active member

    Joined:
    Nov 6, 2002
    Messages:
    2,544
    Likes Received:
    0
    Trophy Points:
    66
    I'm not an expert in this, but the problem seems to lie in the capturing method, not on the AVI compression, nor in the AVI --> MPEG-2 transcoding...
    Maybe it's due to the stuff you used to capture the image from the TV? The video-cam's position with respect to the TV screen? The video-cam's quality? Do you think you need of a filtering-screen in front of the TV?
    Nope, sorry, I'm completely unable to deal with this stuff, I'm a complete newbie in this....
     
    Last edited: Apr 13, 2005
  11. rebootjim

    rebootjim Active member

    Joined:
    May 13, 2004
    Messages:
    2,631
    Likes Received:
    0
    Trophy Points:
    66
    The YUY2 colourspace should be used at 352x240/288 and no larger, with Huffyuv. There's a great deal of technobabble as to WHY this is so, but suffice to say, most people have had much better luck using Huffyuv with a much smaller aspect than you are using.
    You could try RGB, or YV12, you can go larger, but may get dropped frames. You just have to experiment.
    Depending on which encoder you're using, Huffyuv with YUY2 at 352x240 should yeild a very high quality avi.
    I would then suggest you frameserve it to tmpgenc through virtualdub. Try with no deinterlacing and bottom field first.
     
  12. shiroh

    shiroh Guest

    answering the first question; horrible encoded video.

    when you said blocks, sounds like you used cbr, at that low bitrateit will blocks scenes that needs nore bits. cbr only works best at the most max bitrate, 9800kbps.
    so i would suggest 2 pass vbr.
    but be careful, some players don't like bitrate spikes from svcd/vcd.

    so its good to cap it at some point. mine can go up to 6000kbps.

    if you have a dvd burner, its better to use constant quality mode.
    quenc have a constant quantizer mode. an its really much faster than tmpgenc, also with better quality

    tmpgenc will convert it to rgb anyway
     
    Last edited by a moderator: Apr 13, 2005

Share This Page