1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

major DVD burner problems

Discussion in 'DVD / Blu-ray drives' started by falonga, Mar 21, 2007.

  1. falonga

    falonga Regular member

    Joined:
    Oct 6, 2006
    Messages:
    118
    Likes Received:
    0
    Trophy Points:
    26
    please help me! i explain whats happened.
    firstly i noticed that when i mounted an image with daemon tools that it didn't mount at all. and i was a little curious as to why but ignored it. (by the way i know this has nothing to do with my actual DVD drive but its weird how it happened)
    Then when i put a blank DVD in my drive ready for burning, firstly my computer did not run auto play, then when i opened the program for burning my DVD. (Winx Burning master) it didn't recognize any DVD drives)

    well, i have my sony internal DVD-RW drive plugged in, tray opens closes. spins the disc, laser reads it but my computer wont display it at all or read that it is even plugged in.
    and after restarting my system its worse. i now cannot even run the utility "my computer" it just crashes.

    please can someone help me?? I am all out of ideas. ive changed the IDE cable, checked the connections. disconnected floppy drives (in case it was that stopping "my computer" from running) all with no succession.

    any help or suggestions would be great, thanks.

    edit: my dvd drive is Sony DW120ABR
    does anyone know where i can possibly get firmware updates for this?
     
    Last edited: Mar 21, 2007
  2. barricade

    barricade Guest

    Can you explore My Computer when the drive is not plugged in? Maybe that IDE channel has gone bad, since you changed the cables. Try switching channels and see if it works.
     
  3. falonga

    falonga Regular member

    Joined:
    Oct 6, 2006
    Messages:
    118
    Likes Received:
    0
    Trophy Points:
    26
    no i cant browse my computer without the drive plugged in neither.
    how do you mean change channels? plug my DVD drive into a different ide channel?

    Thanks
     
  4. barricade

    barricade Guest

    I don't think it is the drive that is bad because you still can't browse "My Computer" when it is unplugged. See if you can do this: Right click my computer, goto properties, hardware, device manager, expand IDE ATA/ATAPI Controllers, remove the primary and secondary channels and reboot. They will reinstall the drivers when you reboot. I had a problem with one of my hard drives running only in PIO mode the other day and this was how I fixed it. Make sure all of your drives, including dvd burner, are plugged in when you reboot after removing the channels from the device manager.
     

Share This Page