1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

marantz PM66SE

Discussion in 'Receivers and amplifiers' started by xlondonx, Jul 13, 2007.

  1. xlondonx

    xlondonx Member

    Joined:
    Jul 13, 2007
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    11
    Hi all, I am looking for some advice. My Marantz PM66SE powers up ok, however no sound is outputted. I have checked and used different speakers and leads but no joy. If I connect a CD player and listen through head phones then I get sound. Any ideas?
    Thanks
    Paul
     
  2. JVC

    JVC Active member

    Joined:
    Apr 11, 2004
    Messages:
    2,121
    Likes Received:
    0
    Trophy Points:
    66
    Maybe your A/B speaker button got pushed, to the ones you're not using?
     
  3. xlondonx

    xlondonx Member

    Joined:
    Jul 13, 2007
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    11
    checked this already thanks, still no joy. i there any way I can check internal components?
     
  4. JVC

    JVC Active member

    Joined:
    Apr 11, 2004
    Messages:
    2,121
    Likes Received:
    0
    Trophy Points:
    66
    If you don't know what you're doing, I'd stay out of the internal area. It could be dangerous. Even unplugged, if you touch a capacitor wrong, it can hurt you badly.

    Double check all the setup menus, to make sure everything is set right. Make sure the cables from the cd player or dvd player are good. If you're using an optical cable, the fiber inside the cable, could have broken.

    Only other things I know to try is to look in your owner's manual. It should tell you how to reset the receiver to factory settings (like it was when you opened the box). After resetting to factory settings, you'll need to redo the settings you made (sub on, speaker distances, crossovers, etc.). If none of this helps, contact Marantz. They may be able to walk you through a fix.
    Good luck!
     

Share This Page