1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Media Player Classic does not play MP4

Discussion in 'Windows - Software discussion' started by spitfire_, Aug 3, 2012.

  1. spitfire_

    spitfire_ Member

    Joined:
    Mar 14, 2009
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    11
    Hi,
    I recently switched from WinXP to Win7. I can't seem to be able to play MP4-files in WMPC (Home Cinema 64 bit 1.6.2). I have installed FFDSHOW. The MP4 files in question can be played by VLC and WMP without any problems. WMPC just displays Buffering...(0%), but does not progress any further (FFDSHOW does not even have a chance to start). The MP4 files use AVC1, x264 core 120 r2164 da19765.

    MKV files (x264 core 67 r1123tw) do not pose any problems.

    Under WinXP, the MP4 files played, but only after ~10 sec delay. I had the external filter "Nero QuickTime VideoDecoder" installed, but cannot find that anymore.

    What could the cause of this problem be? I would like do avoid installing big driver packages out of fear that it could break something else (e.g. BluRay on WinDVD11). I am fine with testing individual files, though.

    Thank you very much for any advice and kind regards
    - spitfire_
     
  2. JST1946

    JST1946 Regular member

    Joined:
    Jul 15, 2011
    Messages:
    901
    Likes Received:
    2
    Trophy Points:
    26
    Last edited: Aug 4, 2012
  3. spitfire_

    spitfire_ Member

    Joined:
    Mar 14, 2009
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    11
    Thanks for the hint. I will check out the codec pack. I already have VLC installed. While it can play the mp4-files, it has severe sound issues with every file (stuttering), no matter which audio options I choose. I already had trouble in XP with VLC (mostly AC3), but now under Win7 it's just not usable anymore. That's why my hopes lay with WMC.

    edit: All right, at least fixed VLC:
    "That is prolly the same CPU power saving bug that has bothered VLC for years. Currently power saving things like Cool and Quiet etc. don't notice that VLC wants CPU cycles. So CPU frequency is kept too slow, setting the Windows power mode to full power should solve it."
    --> that was exactly the reason for the stuttering.

    edit: Got the WMC problem solved too: in Player -> Options -> Format: MP4 was set to ShockWave. I set it to DirectShow, and now everything works :)
     
    Last edited: Aug 5, 2012
  4. JST1946

    JST1946 Regular member

    Joined:
    Jul 15, 2011
    Messages:
    901
    Likes Received:
    2
    Trophy Points:
    26
    Well glad you got it working.Maybe this will help out someone else with the same problem.
     

Share This Page