1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Messed up controller after disassembly

Discussion in 'PS3 - Modding & Hacking' started by static12, Dec 5, 2012.

  1. static12

    static12 Member

    Joined:
    Dec 5, 2012
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    11
    Hi all,

    I opened up my PS3 controller for a small issue which I solved (ended up undoing "fix" to see if it was the cause of my problem), but after putting it back together I heard a rattling sound every time the controller vibrated.

    The cause of the rattling sound is L2, since when I apply pressure to it the noise stops. Then I opened it up again and a small piece of plastic fell out (intact, doesnt seem broken or anything). This is the picture of the small piece: x.co/qFtl

    I have already disassembled it and put it back together like 5 times, the problem persists. Any help as to where the piece fits and more importantly how to fix the rattling sound issue would be greatly appreciated :)
     
    Last edited: Dec 5, 2012
  2. Cyprien

    Cyprien Active member

    Joined:
    Nov 2, 2003
    Messages:
    2,050
    Likes Received:
    1
    Trophy Points:
    68
    the metal piece that's located on the one of the motors touching the plastic when the motor spins.... in other words check if the white plastic holds both motors and the black back cover providing the pressure to hold them in place... also check if the small plastic piece didn't brake from the back cover... if it did brake and no pressure is applied once closed just use some hard foam to apply pressure you can find hard foam in most packages now a days.. including what comes with a ps3... that should solve the problem ^__^
     
  3. static12

    static12 Member

    Joined:
    Dec 5, 2012
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    11
    Managed to fix the issue! :D After numerous more disassemblies I put some tape behind the L2 plastic trigger piece and that seemed to solve it!

    I do however have a new problem and that is that there is some serious squeaking whenever I press either R2 or L2, but I'll have a look at that when I get home. Any suggestions to fixing this issue?

    Thanks!
     

Share This Page