1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Mod or not to Mod

Discussion in 'Sony PSP - Mod and firmware discussion' started by Spyder22, Apr 17, 2007.

  1. Spyder22

    Spyder22 Regular member

    Joined:
    Jan 26, 2005
    Messages:
    323
    Likes Received:
    0
    Trophy Points:
    26
    Im considering downgrading the firmware on my psp to 1.5 so i can play games and homebrew off my 2gb memory stick. My question is can i use a computer to transfer game files on a umd that is in my psp to the memory stick? And i have noticed some games require a certian firmware version in order to play. Will i be able to play those games if i have an earlier firmware version?
     
  2. Ephumuris

    Ephumuris Member

    Joined:
    Apr 17, 2007
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    11
    If you downgrade to 1.5 then you might aswell go from 1.5 to a custom firmware. 3.30 OE-A to be exact.

    You will be able to play games and homebrew off your memory stick and also play games that require the very latest firmware.

    If you stick with 1.5 then there are a lot of games that REQUIRE a higher firmware version to be able to run.

    PSP firmwares up to 3.03 are downgradable if you are any higher than you are stuck.
     
  3. Spyder22

    Spyder22 Regular member

    Joined:
    Jan 26, 2005
    Messages:
    323
    Likes Received:
    0
    Trophy Points:
    26
    i have decided i want to use the 3.30 OE-A firmware on my new psp. i looked under system settings :system version, it says i have 2.60 . are there any percautions i need to take? Is my psp fully compatable with this new custom firmware, and is it compatable with all the programs used to install the firmware? is there anything i need to buy like a modchip?
     
  4. fultonla

    fultonla Guest

    ok you first of all need to use the right downgrader.
    i recomend upgradeing to 2.71 a downgradeing from there it is really easy.

    if you have a ta-082 board (determine here)

    if you do use the 2.71 downgrader in my sig

    if you are sure you dont have a ta-082 use this one
    once you are at 1.5 you can upgrade to any custom firmware you want.
    i recomend either 3.03 oe-c or 3.30 oe-a

    make sure you read the instructions carefully and doublecheck you know how to do everything right.

    just dont do something stupid like turn it off and you will be fine
    goodluck and have fun :)

    EDIT:changed downgrader to full downgrader
     
    Last edited by a moderator: Apr 19, 2007

Share This Page