1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Modded the PS2... now it doesn't work

Discussion in 'PS2' started by mbeezy, Nov 26, 2004.

  1. mbeezy

    mbeezy Guest

    But all hope isn't lost! It worked for quite a while, perfectly. Then, it started to get some read error, so I would tap the PS2, and it would read normally again for a bit.

    So, I decided to open her up again and try to clean the laser, and also tighten all of the ribbons going into the disc drive. When I put it back together and hit reset, I got a red light on that button. Black screen. Also, the door open button isn't working.

    I do NOT think it is the modchip, as I was careful with the ps2 when I opened it, and it worked fine. Help!
     
  2. Willmatic

    Willmatic Guest

    One of your soldering points has come loose. If you did it yourself, open it up and find the loose connection. If you had it done by someone, take it back to them and tell them your problem.
     
  3. mbeezy

    mbeezy Guest

    Thanks. You are sure it must be the mod chip and not the drive itself?
     
  4. Willmatic

    Willmatic Guest

    I would say it's most likely a loose connection because of what you mentioned about tapping the console. The loose contact probably made a temporary connection until the natural vibrations from the console caused it to move.
     

Share This Page