1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

My box is dead

Discussion in 'Digital TV - UK & Europe' started by IrishDave, Nov 30, 2007.

  1. IrishDave

    IrishDave Member

    Joined:
    Aug 14, 2007
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    11
    I noticed yesterday that my starview - The Box is dead.
    When I switch the power on button at the rear of the box - there is a flicker of power from the clock, but then nothing.
    It has worked fine since I got it 3 months ago.
    Should I call the manufacturer or is there something I can do to correct this problem?
     
  2. sc0user

    sc0user Active member

    Joined:
    May 31, 2007
    Messages:
    13,111
    Likes Received:
    0
    Trophy Points:
    96
    Are you sure its The Box or is it the Starview 1 as you said you bought it 13 months ago more than likely it is a SV1.
     
  3. IrishDave

    IrishDave Member

    Joined:
    Aug 14, 2007
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    11
    I bought it 3 months ago.
    It is The Box - starview 2
     
  4. sc0user

    sc0user Active member

    Joined:
    May 31, 2007
    Messages:
    13,111
    Likes Received:
    0
    Trophy Points:
    96
    Sorry I need glasses :) Have heard of SV1s going down and they can be jtagged, but have not jtagged an SV2 though I assume the tsop is similar and may work. Although I think your problem is more likely to be a hardware problem, more than likely on the PSU maybe a blown or bulging cap as you say you have some power.

    It should still be under warranty give your supplier a call, if you get no joy there, bring it to a TV repair shop and they may see if it can be repaired.
     
  5. IrishDave

    IrishDave Member

    Joined:
    Aug 14, 2007
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    11
    Cheers mate!

    I will give them a call and see what they have to say.
     

Share This Page