1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

need downgrader for psp v 3.40

Discussion in 'Sony PSP - Games' started by stefffrew, Oct 24, 2007.

  1. stefffrew

    stefffrew Member

    Joined:
    Jan 29, 2007
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    11
    any one help me oot ,trying to downgrade a psp 3.40 to 1.50
     
  2. cee43ja1

    cee43ja1 Regular member

    Joined:
    Sep 14, 2007
    Messages:
    4,135
    Likes Received:
    1
    Trophy Points:
    46
    you need a copy of lumines: puzzle fusion and need to upgrade to 3.50. 3.40 does not have a downgrader.

    you can find instructions on how to downgrade HERE.


    remember, you take FULL RESPONSIBILITY for what happens. you cannot blame anyone but yourself if your psp bricks.
     
    Last edited: Oct 24, 2007

Share This Page