1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

need help please?

Discussion in 'PS2 - Software boot discussion' started by da_one, Aug 10, 2004.

  1. da_one

    da_one Guest

    i have a ps2 version 1 (us),what version of swap magic should i get 3.0 or 3.2?does it really matter if there pal or ntsc version?
     
  2. sly_61019

    sly_61019 Senior member

    Joined:
    Jun 28, 2003
    Messages:
    9,522
    Likes Received:
    0
    Trophy Points:
    116
    only post your question once. check your other post for the answer.
     

Share This Page