1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

need help- psp no display

Discussion in 'Sony Handhelds' started by jlcioi, Jul 19, 2007.

  1. jlcioi

    jlcioi Guest

    hi,
    Need help!-psp has no display after restoring defalut settings. successfully upgraded it from 1.5v to 3.1. After restoring default settings, psp didn't reboot. i turned it on, it has power and sounds but no display. well, sometimes it displays(back to it's japanese language) but when i press any button, display goes off.
    anyone who knows how to fix this? thanks:)
     
  2. mrmcman

    mrmcman Guest

    press the brightness button (square symbol, next to the musical note)
     
  3. jlcioi

    jlcioi Guest

    hi,
    did it already but still wont display. sometimes display appears but when i press a button, it goes off? any button i can press to hard reset my psp? thanks:)
     
  4. jlcioi

    jlcioi Guest

    or is it safe to flash it with the 3.1 v? i was able to enter usb mode and it's detected by my pc. Need your advice. thanks again:)
     
  5. mrmcman

    mrmcman Guest

    wow, this is really strange. maybe take the battery out for at least 2 days and then pop it back in. or try to boot a game. and thats all i got.
     
  6. jmscobra

    jmscobra Member

    Joined:
    Jul 12, 2007
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    11
    try flashing it (thats if you have cfw)
     

Share This Page