1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Need help with a Rmvb file - double audio

Discussion in 'DivX / XviD' started by cyprusrom, Dec 12, 2007.

  1. cyprusrom

    cyprusrom Active member

    Joined:
    Jan 5, 2006
    Messages:
    5,722
    Likes Received:
    1
    Trophy Points:
    96
    Hi everyone,
    Been a while since I stopped by!
    I have a RMVB file that has more audio than I need. Basically it plays 2 sound tracks at the same time.How do I get rid of one of them? How can I strip off one of the soundtracks?
    Thanks for your time.
     
    Last edited: Dec 12, 2007
  2. attar

    attar Senior member

    Joined:
    Jun 17, 2005
    Messages:
    11,504
    Likes Received:
    29
    Trophy Points:
    128
    If it has two audio streams (only the selected one should play) then RMMUXER will show the video and both audio streams.
    Select one video and one audio and merge the new file.
    Save as .rmvb

    If the problem is that there is one audio stream and the two channels have different audio, this tool won't do anything.



    http://www.videohelp.com/tools/RMMuxer
     
  3. cyprusrom

    cyprusrom Active member

    Joined:
    Jan 5, 2006
    Messages:
    5,722
    Likes Received:
    1
    Trophy Points:
    96
    @attar
    Thanks much for your suggestion. I tried the RMMUXER, and I guess it has indeed one audio stream and the two channels have different audio. Thanks anyway, at least I know the exact problem now. Maybe someone has another ideea.
     
  4. attar

    attar Senior member

    Joined:
    Jun 17, 2005
    Messages:
    11,504
    Likes Received:
    29
    Trophy Points:
    128
    There is a method here for converting RMVB to AVI using VirtualDubMod.

    In your case, you would load the file, then save the audio as a wav file - leave VDM open.
    If the audio was one per stereo channel, you can load the wav into 'Audacity' and split the left and right components and delete the offending one.
    Save the good audio as a new wav and load it back into VirtualDubMod, then save the video and audio as a new AVI file.


    http://www.jakeludington.com/dv_hacks/20051210_how_to_convert_rmvb.html
     
  5. cyprusrom

    cyprusrom Active member

    Joined:
    Jan 5, 2006
    Messages:
    5,722
    Likes Received:
    1
    Trophy Points:
    96
    Thanks,
    I am at work now. I will try when I get home.
    I had the same problem some time ago while trying to view a rental DVD. It only had one audio track.The only way I got around it was to unplug one of the audio cables, red/white.It worked. I guess is nothing like that that i can do with the computer?
    I will let you know how it goes.
    Thank you again.
     
  6. cyprusrom

    cyprusrom Active member

    Joined:
    Jan 5, 2006
    Messages:
    5,722
    Likes Received:
    1
    Trophy Points:
    96
    Hello again,
    So, I used the Real Media Muxer to strip the audio from my video. The file obtained was a *.RM audio file. Audacity saw it as an mp3 file, loaded it but did not play it. So I converted the file to a WAV file first, tried to play with it in Audacity ( http://audacityteam.org/wiki/index.php?title=Vocal_Removal ), but no luck.I converted the audio to an *.mp3 stereo, tried to play with that one, still no luck. It seems like when I separate the right or left channel, the remaining channel is an identical mono copy of the the original stereo file, with both languages still on. Is it possible that something changed during conversion from RM to wav/mp3 and that's why is not working?
    Any suggestions welcomed. Thank you.
     
  7. attar

    attar Senior member

    Joined:
    Jun 17, 2005
    Messages:
    11,504
    Likes Received:
    29
    Trophy Points:
    128
    When you got rid of it by disconnecting the cable to one channel, it implies that there are two separate channels, so Audacity should split them using the splitting feature.
    I did the same as you by converting the .rm file to mp3 with the 'Jodix' converter and Audacity accepted it and I split the channels ok.
    Unfortunately, I don't have a 'bad' file to test it with.
    If you wish, upload the audio - or a fraction and we can all test it.

    You can get a WAV file using the other method with VirtalDubmod that Audacity will recognize.
     
    Last edited: Dec 14, 2007
  8. cyprusrom

    cyprusrom Active member

    Joined:
    Jan 5, 2006
    Messages:
    5,722
    Likes Received:
    1
    Trophy Points:
    96
    Hello attar
    Well, it is possible that I did something wrong when using Audacity, although I followed the guide closely. For conversion of the RM file I used Switch Plus, from http://www.nchsoftware.com/index.html
    Where/how can I upload a fraction of the file?
    Thanks.
     
  9. attar

    attar Senior member

    Joined:
    Jun 17, 2005
    Messages:
    11,504
    Likes Received:
    29
    Trophy Points:
    128
    Rapidshare would do.
    Browse, upload and copy the link - might want to test it too.

    http://rapidshare.com/
     
  10. cyprusrom

    cyprusrom Active member

    Joined:
    Jan 5, 2006
    Messages:
    5,722
    Likes Received:
    1
    Trophy Points:
    96
  11. attar

    attar Senior member

    Joined:
    Jun 17, 2005
    Messages:
    11,504
    Likes Received:
    29
    Trophy Points:
    128
    Both channels have the same audio in both clips.
    I don't have anything to offer for the two asian voice clip, but the Polish over-dubbing could be doctored by selecting that part and 'Edit' 'Silence', then pick a music bit the same size and copy paste over it or use one of the 'Effects' on the section, perhaps a fade out and in.
    Good luck.
     
  12. cyprusrom

    cyprusrom Active member

    Joined:
    Jan 5, 2006
    Messages:
    5,722
    Likes Received:
    1
    Trophy Points:
    96
    @attar
    Thank you for your help. Well, at least I have been initiated a tiny bit in audio processing :~)!
    I could use the silencing tip for the Polish dubbing, but sometimes it overlaps with the English track.
    I was reading some Audacity forums, and some people suggested that once you convert the file, the audio in some instances gets kinda "messed up" or something, and the easy removal could be done maybe using the original audio file, for example if I had access to the Polish dubbed DVD, probably the channels would have different sound tracks ,and the unplug audio cable trick would also work. maybe. I don't know!
    It is not really that important that it gets fixed, it is more like a challenge now.
    Thank you anyway for your time!
     
    Last edited: Dec 14, 2007
  13. ac108

    ac108 Member

    Joined:
    Mar 15, 2008
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    11
    Hi Attar & Cyprusrom,

    I have the same problem and was directed to this thread. I have downloaded both VirtualDubMod and Audacity. I used VDM to extract the sound tracks from the AVI file by doing the following steps:

    Start VDM.
    Open video file.
    Select Stream List.
    Save WAV.

    I then start Audacity:

    Open the WAV file saved by VDM.
    Remove the unwanted track (left or right).
    Set the remaining track to mono.
    Export the good track as a WAV file.

    Now my problem is how to "load it back into VirtualDubMod, then save the video and audio as a new AVI file".

    Appreciate your guidance. Thanks.
     
  14. attar

    attar Senior member

    Joined:
    Jun 17, 2005
    Messages:
    11,504
    Likes Received:
    29
    Trophy Points:
    128
    Load the AVI file in VirtualDubMod, then click 'Streams' 'Stream list'.

    Disable the existing audio stream by double clicking on it (hatch marks) then click 'Add' to locate and load the new wav.

    Right click on the new audio stream and 'Full Processing' 'Compression' and (if you installed the Lame filter) select 'Lame mp3' 48,000 128 CBR Stereo, if appropriate - 'OK'.

    Click 'Video' 'Direct Stream Copy' (because you don't want to recompress the video) and 'File' 'Save As...' and elect AVI as the type.
     
  15. ac108

    ac108 Member

    Joined:
    Mar 15, 2008
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    11
    Hi attar, cyprusrom. Sorry for such a late response. Have been trying, and of course made some mistakes...... It's DONE now. The procedure works. One thing is that after exporting the good wave, the new wave file did not play in Windows Media Player. When I played it again with Real, I have to select mono. When I merge this saved sound track to the video, it works. Thanks a lot for your help. Very much appreciate it. Regards.
     

Share This Page