1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Need Help with firmware 3.52

Discussion in 'Sony PSP - Mod and firmware discussion' started by naruto820, Oct 14, 2007.

  1. naruto820

    naruto820 Member

    Joined:
    Oct 14, 2007
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    11
    Actually I don't know much about psp firmware and stuff. I am running the official 3.52 firmware, but I want to play ISO games. I heard u need to have a custom firmware to run ISO files. So is there any way to upgrade from official 3.52 to M33 3.52 updates. If so can u guys help me plz. THX =]
     
  2. marlino23

    marlino23 Regular member

    Joined:
    Apr 1, 2007
    Messages:
    2,821
    Likes Received:
    0
    Trophy Points:
    46
    you need to downgrade to firmware 1.50 using a Pandora's Battery and Magic Memory stick. you cannot downgrade any other way yet. however you need a friend with a 3.52 M33 or any cfw psp to help you make that.
     
  3. naruto820

    naruto820 Member

    Joined:
    Oct 14, 2007
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    11
    Why do I need to downgrade it to 1.50 can't I just downgrade/upgrade to M33 3.52-3/4?
     
  4. cee43ja1

    cee43ja1 Regular member

    Joined:
    Sep 14, 2007
    Messages:
    4,135
    Likes Received:
    1
    Trophy Points:
    46
    no. you need to downgrade back to 1.50 because that's the only firmware that will allow unsigned code. custom firmware is completely different from official firmware. if you try to upgrade to m33, you'll get a error.

    all custom firmware requires to be downgraded to 1.50, before upgrading.
     
    Last edited: Oct 14, 2007
  5. naruto820

    naruto820 Member

    Joined:
    Oct 14, 2007
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    11
    ooo ok thx. So i need another psp that has a CFW or FW 1.50, so I have to put my battery into the FW 1.50 psp, Download the Pandora Battery thing and install it. Is that all?
     

Share This Page