1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

need help with installing a working ASPI layer

Discussion in 'DVD±R for advanced users' started by sylvelin, Apr 7, 2005.

  1. sylvelin

    sylvelin Member

    Joined:
    Apr 6, 2005
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    11
    hi guys, i'm new here and this is my 1st post!
    i seem to be encountering a problem with reading of discs.
    hope someone can help me out here..

    i've got a ASUS CRW-1610A and a Sony DVD RW DRU-720A.
    The DVD RW drive is connected as "Master" while the CD RW drive is connected as "Slave".
    Both are sharing the same IDE cable with the DVD RW drive connected to the top connector and the CDRW drive connected to the middle connector.

    - Went to Device Manager and both drives are working well.
    - Went to My Computer and both drives are labeled correctly when there no discs inserted (ie DVD-RW drive and CD-RW drive).

    Here's the problem..

    No matter what discs i insert into both drives (VCD, original DVD, normal software installation CDs etc), when i double click the drive icon, the contents are completely empty and i right click for "properties",
    used space=0bytes and free space=0bytes also.

    However, i tried inserting a music CD into my DVD-RW drive ('coz that's the one that i connected the audio cable to), same problem happened (as in, windows explorer does not display the contents of the CD) but when i launch
    Windows Media Player direct and click the "open" function, it can detect that there's a music CD in there and i can play the tracks.

    I tried using the same method for VCDs, that means i opened my Creative Media Source Player/Winamp player first then tried to use the "open" function but contents of the drive were always empty (although "all files" option was already selected).

    Then, I tried to burn some data files (mixture of .exe, pictures, mp3s, avi files) to a Sony DVD-R disc and tested ok.
    Tried using my DVD-RW drive to read the disc that i had burned but same problem occurred (no contents).
    Testing reading the contents of the disc on my sister's fujitsu laptop and it was ok.

    Now, i'm even trying to go to DOS mode to try to access to my DVD-RW or CD-RW drive but i get the error reply "incorrect function".

    Ppl i've consulted narrow it down to either OS or motherboard problem and i was advised to reinstall my OS (WinXP Professional w SP2). But i'm not sure if it'll work as my 2 drives can't seem to read any CDs.

    Am really puzzled by this problem and really hope someone can help or provide some guidance. Sorry for the lengthy description coz I wanted to get all the information down. Many thanks in advance!
     
  2. sylvelin

    sylvelin Member

    Joined:
    Apr 6, 2005
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    11
    some more info as i'm trying ways and means to fix my problem..
    had this problem when running the ASPI intstaller..

    "Step 1 of 3 : REGISTRY MODIFIED FOR ASPI32"
    1 file(s) copied
    "Step 2 of 3 : COPYING ASPI32.SYS"
    This process cannot access the file because it is being used by another process.
    0 file(s) copied
    "Step 3 of 3 : COPYING WNASPI32.DLL"

    any idea why step 2 of 3 failed??

    Thereafter, i ran Nero InfoTool and this is wat i got:

    ASPI Information
    ----------------
    System ASPI : ASPI installation is corrupted

    WNASPI32.DLL : 4.71 (0002) 45056 bytes July 17, 2002
    ASPI32.SYS : 4.60 (1021) 25244 bytes September 10, 1999
    WINASPI.DLL : 4.60 (1021) 5600 bytes September 10, 1999
    WOWPOST.EXE : 4.60 (1021) 4672 bytes September 10, 1999

    Nero ASPI : ASPI installation is corrupted

    wnaspi32.dll : 4.60 (1021) 45056 bytes September 10, 1999

    any advice guys?? thanks in advance again!
     
  3. bassnut

    bassnut Regular member

    Joined:
    Jun 11, 2013
    Messages:
    142
    Likes Received:
    0
    Trophy Points:
    26
  4. Noqoilpi

    Noqoilpi Regular member

    Joined:
    Jan 29, 2005
    Messages:
    412
    Likes Received:
    0
    Trophy Points:
    26
    from Adaptec

    I do not even use ASPI. Just SPTI with DVD Decrypter.
     
  5. sylvelin

    sylvelin Member

    Joined:
    Apr 6, 2005
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    11
    thanks bassnut & Noqoilpi for ur info..
    i actually copied a copy of the "wnaspi32.dll" from another WinXP PC and pasted it into my C:\Windows\system32 folder..

    so far, i've run the ASPI checker and Nero InfoTool and both have said that ASPI layer is installed and functioning properly..

    All that's left is for me to reboot my PC and pop in a CD to test if it can be read *crosses fingers*...

    actually, i'm not even sure wat i'm doing now is even related to my main problem (which is unable to view/display the contents of any CD/DVD)..

    well..here goes.. will update again later!
     
  6. sylvelin

    sylvelin Member

    Joined:
    Apr 6, 2005
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    11
    [bold]IT WORKS!!![/bold]

    :)

    now both my DVD-RW and CD-RW drives are able to read CDs/DVDs..
    phewww...
     

Share This Page