1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Need some help with my psp's firmware.

Discussion in 'Sony PSP - Mod and firmware discussion' started by James80, Jul 8, 2007.

  1. James80

    James80 Member

    Joined:
    Jul 8, 2007
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    11
    So yesterday I bought a used psp. The guy told me it had a "custom version" on it.so i get home to see that only some of my .iso games work and some dont. now I was looking at theses threads all night and im confused. I have a fw 2.71 it says. I dont know what emulator I am using but I can play some .isos. I went in recovery mode and thought I would post here for help before bricking it.
    ...thanks
     
  2. James80

    James80 Member

    Joined:
    Jul 8, 2007
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    11
    Sorry to double post but I dont see an edit post button.
    The PSP Is Japanize apperently although I dont know how to tell. I lookerd in the UMD bay and there was no writing.I got a 1gig card with it and do not no what version it is running. It says 2.71 is there a downgrade for it?
    Also I seem to be able to play only a few games. Games such as SoCom FTB2 and Burnout legends do not work.
    Sorry kinda new to the psp world. Hope I made things clearer for you.
     
  3. CKhaleel

    CKhaleel Regular member

    Joined:
    Feb 26, 2007
    Messages:
    1,669
    Likes Received:
    0
    Trophy Points:
    46
    You can downgrade.
     
  4. James80

    James80 Member

    Joined:
    Jul 8, 2007
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    11
    How do I go about downgrading? DO I have to have a cirtin custom firmware already running? Whats the latest custom fireware release and is it a UMD exploit or what do I need?
     

Share This Page