1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Nero hangs scanning SCSI/IDE bus....

Discussion in 'DVD±R for advanced users' started by Mr_Taz_UK, Aug 31, 2004.

  1. Mr_Taz_UK

    Mr_Taz_UK Regular member

    Joined:
    Mar 9, 2004
    Messages:
    522
    Likes Received:
    3
    Trophy Points:
    26
    My copy of Nero worked fine before installing XP SP2 !!

    I think I may have a solution.

    This appears to be caused by the process RMADEC.EXE that is spawned by Nero and then freezes on some systems. To get around this on my system I have written a batch file as follows:

    @echo off
    cd c:\program files\ahead\nero
    start nero.exe
    @ping 127.0.0.2 -n 5 -w 1000 > nul
    taskkill /F /IM rmadec.exe

    For those of you unfamiliar with batch files, simply open notepad and enter the text shown above. Then save on your desktop as nero.bat. Double click to start it and that should be that.

    The @ping line causes a delay of 5 seconds. This should be enough time for the RMADEC process to start before the taskkill line trys to stop it. If you have an older machine you may want to increase this from 5 to 6 or higher.

    If your not comfortable with batch files then simply open task manager before launching Nero, Start Nero and look for RMADEC.EXE in the process list and end it. Nero will start as normal.

    Comments please, let me know how you get on.....

    Happy Burnin !

     
  2. ccampbell

    ccampbell Regular member

    Joined:
    Mar 24, 2004
    Messages:
    757
    Likes Received:
    0
    Trophy Points:
    26
    When you say you think you have a solution, does this mean that the process you have outlined worked for you?


    I'm very interested in your results, and any others who have run into this issue and used this process to resolve it.

    If this does solve your issue, I wish to pass this on to our Engineers so they can look into this issue so as to make these steps unnecesary.

    P.S. I have not been able to duplicate this issue on any of my systems in the US lab with SP2 installed.

    Regards,

    Craig

    Ahead Software
    USA
     
  3. Mr_Taz_UK

    Mr_Taz_UK Regular member

    Joined:
    Mar 9, 2004
    Messages:
    522
    Likes Received:
    3
    Trophy Points:
    26
    Hi Craig,

    Yes this solution works for me.

    However, just because I started getting problems after SP2 does not mean that SP2 caused the problem. Others have had similar issues without updating XP.

    If this fixes your problem does that mean I get a free copy of version 7 when it's released? He he he :eek:)

    P.S. 6.3.1.20 did not fix the problem for me.

    P.P.S. I just had another look at this and think SELFDEL.EXE also has a role to play. I believe it is used to create a self deleting executable (whilst running)

    see:

    http://freespace.virgin.net/james.brown7/tuts/selfdel.htm

    is this what your developers are using / trying to use? Perhaps a previous XP 'security patch' broke it as SELFDEL could be used maliciously.

    Feel free to pass on my findings, Happy Hunting.

    Taz :eek:)
     
    Last edited: Aug 31, 2004
  4. ccampbell

    ccampbell Regular member

    Joined:
    Mar 24, 2004
    Messages:
    757
    Likes Received:
    0
    Trophy Points:
    26
    Hi Mr_Taz_UK,

    Since it appears to have resolved at least one other users issues with Nero crashing, and your issue with Nero hanging during scanning for devices, I've generated a Bug Report on this issue.

    I've also included our Tech Support Managers from the US and Germany in the Bug Report so they can follow this issue closely to pass the results on to our Tech Support team.

    I'll let you know what our Engineers come up with as the cause and solution for this.

    Thanks for the excellant feedback. :)

    Regards,

    Craig

    Ahead Software
    USA
     
  5. Mr_Taz_UK

    Mr_Taz_UK Regular member

    Joined:
    Mar 9, 2004
    Messages:
    522
    Likes Received:
    3
    Trophy Points:
    26
    Glad I could help :eek:)

    I have added two lines to the batch process to remove selfdel.exe

    @ping 127.0.0.2 -n 5 -w 1000 > nul
    taskkill /F /IM selfdel.exe

    Hopefully this can be fixed soon.

    Cheers

    Taz
     
  6. oscarm

    oscarm Member

    Joined:
    Aug 31, 2004
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    11
    hello guys i am a newbie and really stupid
    so please help.
    i have dvd shrink dvd decrypter
    and nero
    but the best i could do was copy two movies on one disc back to back
    how do i create a menu to choose what i want to watch
    please help
     
  7. Mr_Taz_UK

    Mr_Taz_UK Regular member

    Joined:
    Mar 9, 2004
    Messages:
    522
    Likes Received:
    3
    Trophy Points:
    26
    This is the wrong post to be asking in really, but you could try NeroVision Express.

    www.nero.com

    Alternatively, check out the guides section.

    Taz

    :eek:)
     
    Last edited: Sep 1, 2004
  8. Mr_Taz_UK

    Mr_Taz_UK Regular member

    Joined:
    Mar 9, 2004
    Messages:
    522
    Likes Received:
    3
    Trophy Points:
    26
    Craig,

    The RMADEC / SELFDEL issue also seems to cause the following:

    stops recode from starting
    Stops express and vision express from starting
    causes DVD Shrink to freeze.

    I'm spotting a pattern here..........

    The issue seems to be that SELFDEL does not start until RMADEC has been manually terminated. This kind of defeats the object of SELFDEL.

    So, is it a Nero problem, or a windows problem?

    I will sit back now and watch this thread, leave it in your capable hands.

    Regards

    Taz :eek:)

     
  9. ccampbell

    ccampbell Regular member

    Joined:
    Mar 24, 2004
    Messages:
    757
    Likes Received:
    0
    Trophy Points:
    26
    Thanks Mr_Taz_UK,

    I'll pass this additional information you provided on to our Engineers.

    I hope to have some information for you ASAP. :)

    Regards,

    Craig
     
  10. Voland22

    Voland22 Guest

    Hanging on startup is a bug in the Nero 6 new versions (15-20) itself. It looks like Nero became profitable and consequently all good programmers were thrown out for not share the profit. This is normal practice for "free market".

    Here is batch file for Win 2000 to start Nero. The program "pskill" can be found on Googl, downloaded and copied on drive C:\.

    @echo off
    cd c:\
    pskill RMADEC.EXE
    @ping 127.0.0.2 -n 5 -w 1000 > nul
    pskill selfdel.exe
    Copy it to Notepad and save as Nero.bat Create the shortcut on the desktop and click several seconds after clicking any Nero program, in case it hungs.
    I am not a programmer, only lamer, but script which I create works perfectly.

    Programming is not a science, it is handcraft.
     
  11. tps

    tps Member

    Joined:
    Sep 4, 2004
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    11
    not quite the same, but obviously connected...
    using win2k(SP4) nero seems to run ok here, but I find multiple instances of selfdel.exe left in mem after closing nero. Seems I get one for each "new" command issued.

    I liked your scripts, but like using w2k more :)... anyone know if there a similar command to taskkill for w2k ???
     
  12. PitterPat

    PitterPat Member

    Joined:
    Sep 7, 2004
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    11
    Hi,

    Good work! Killing the rmadec.exe process works for me too!

    I used task manager instead of the script and I don't have sp2 yet.

    Thanks again, PP
     
  13. Hooch

    Hooch Member

    Joined:
    May 19, 2004
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    11
    Or to start Nero automatically;

    @echo off
    cd c:\program files\ahead\nero
    start nero.exe
    @ping 127.0.0.2 -n 10 -w 1000 > nul
    cd c:\
    pskill RMADEC.EXE
    pskill selfdel.exe

    Increased the delay to 10 secs. Anything shorter wouldn't terminate the processes....

    B.t.w. here's the url for pskill;

    http://www.sysinternals.com/files/pskill.zip

    Hooch
     
    Last edited: Sep 10, 2004
  14. Mr_Taz_UK

    Mr_Taz_UK Regular member

    Joined:
    Mar 9, 2004
    Messages:
    522
    Likes Received:
    3
    Trophy Points:
    26
    That setting is dependant on the speed of your computer. what we could really do with is a proc watch script. Anyone up to the job?

    Craig, any news yet?

    Anyways, you guys can re-write my batch file all you like. Lets not forget who actually found a fix in the first place !!!

    Lets hope Ahead Software corrects this quickly. Even with the batch file its really annoying as it seems to affect almost the entire suite, so you are forever killing the process that should look after itself. I for one am thinking of ditching it for the new Roxio.

    B.T.W.

    taskkill.exe is resident in XP if your running XP you dont need anything else.

    P.S. both rmadec and selfdel have child processes so maybe we should be using taskkill with the /t option? comments please....

    Taz
    _X_X_X_X_X_[small]Even my cat hates Bill Gates ![/small]
     
    Last edited: Sep 10, 2004
  15. ccampbell

    ccampbell Regular member

    Joined:
    Mar 24, 2004
    Messages:
    757
    Likes Received:
    0
    Trophy Points:
    26
    I looked up the Bug report, and its been assigned to an engineer, but I do not know what the status is other than that.

    I'll drop the Engineer a line and see if I can get any solid feedback.

    Regards,

    Craig
     
  16. Hooch

    Hooch Member

    Joined:
    May 19, 2004
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    11
    Taz,

    The fix was long known by me before I even found this forum. I was aware that if you killed the RMADEC.EXE, it would allow Nero to start properly however I wasn't aware that the selfdel.exe had something to do with it as well. I never really looked at putting it in a batch file, I just killed it in the taskmanager. Then again, I don't use Nero all that much.

    Hooch
     
  17. james_m12

    james_m12 Member

    Joined:
    Sep 17, 2004
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    11
    Yes this worked for me too - many thanks
    It cured the issue with DVDShrink and Nero (with latest patches)

    Will create batch file to make it easier
    Thanks for the help
     
  18. Hooch

    Hooch Member

    Joined:
    May 19, 2004
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    11
    Just uninstalled Nero and installed Nero 6.3.1.25 and it starts up normal. No more problem hanging. Just thought I'd let you all know.

    Hooch
     
  19. Jeanc1

    Jeanc1 Guest

    Lucky you -- [bold]Hooch [/bold]

    I have been trying for two days to download that updated version from Ahead -- No luck -- it trickles out at less then 4 Kb/sec and runs out of time on their server.

    Will wait till the rush is over !

    Good Luck in your burning !
     
  20. Mr_Taz_UK

    Mr_Taz_UK Regular member

    Joined:
    Mar 9, 2004
    Messages:
    522
    Likes Received:
    3
    Trophy Points:
    26
    Ok folks, here's what I did.

    Uninstall everything from Nero, Run the clean tools.

    www.nero.com/en/Clean_Tools.html

    install 6.3.1.25 and run. IT WORKED WHOO !!!

    So then I re-installed package 2 version 2.1.2.18

    and.....It broke everything again, the RMADEC / SELFDEL issue is back.

    Nice try Nero, but you aint got it quite right yet.

    T
    _X_X_X_X_X_[small]Even my cat hates Bill Gates ![/small]
     
    Last edited: Sep 24, 2004

Share This Page