1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New ISO's-Can't get to work on 1.5 PSP

Discussion in 'Sony PSP - Mod and firmware discussion' started by vissim34, Jun 12, 2007.

  1. vissim34

    vissim34 Member

    Joined:
    Jul 20, 2006
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    11
    I have a PSP running 1.5 and Devhook 0.44 ( I know that's old but works great to date). Noticed recently that some new releases eg. Valhalla, Crush etc wont load- Do I need a later Version of Devhook or is it to do with needing 3.03 Open Edition-Don't know much about the latter and if it is this does anyone have a good link for it with instructions as concerned about bricking the PSP- I am not a PSP techy guru so easy to understand responses really appreciated.

    Many Thanks
     
  2. djmazz

    djmazz Regular member

    Joined:
    Dec 18, 2006
    Messages:
    647
    Likes Received:
    0
    Trophy Points:
    26
    stick to one thread.
     

Share This Page