1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

new psp and can use some help please

Discussion in 'Sony PSP - Mod and firmware discussion' started by stryker69, Sep 29, 2007.

  1. stryker69

    stryker69 Guest

    hello,
    i just bought my first psp last night and from what the system info tells me its got system software version 3.51. and i would like to know if i am going to be able to down grade my system at all? i really want for now to just be able to use a cheat program i heard about for the psp called "cwcheat" i have a usb conector that goes to my psp and the only memory card i could buy was a magicgate 32mb memory stick duo. but if anyone needs any more info for my psp, just let me know what i need to look for on it. thank you all verry much for youre time and help.
     
  2. larrylje

    larrylje Active member

    Joined:
    Jan 4, 2005
    Messages:
    12,506
    Likes Received:
    0
    Trophy Points:
    96
    The only option you have is using a Pandora battery. you will need a PSP that has 1.50 or some other custom firmware on it.

    Your official 3.51 PSP will not be able to create it.

    HERE is a link on how to create a Pandora Battery.
     
    Last edited: Sep 29, 2007
  3. stryker69

    stryker69 Guest

    so, do you think someone will release a downgrader for the 3.51 someday? i guess i will just play my psp the way its is for now. but thanx for the reply to me.
     
    Last edited by a moderator: Sep 30, 2007
  4. kikzm33z

    kikzm33z Regular member

    Joined:
    Aug 21, 2007
    Messages:
    1,911
    Likes Received:
    0
    Trophy Points:
    46
    I don't think there will ever be a 3.51 downgrader as Pandora Battery was released.If Pandora never existed then I think M33(A.K.A Dark_AleX)would have made a 3.51 downgrader but not a 3.52...But Pandora is out and I don't think any more downgraders will be created.You either make a strong request to DaX on making a 3.51 downgrader or just get the Pandora Battery.
     
  5. stryker69

    stryker69 Guest

    then what if my psp was upgraded to 3.71? but yea i think a downgrader for 3.51 is verry much needed. but the battery trick seems to make some scence to me.
     
  6. larrylje

    larrylje Active member

    Joined:
    Jan 4, 2005
    Messages:
    12,506
    Likes Received:
    0
    Trophy Points:
    96
    Any firmware that is 3.51 or higher will need a Pandora battery to downgrade it.
     

Share This Page