1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

New to PSP

Discussion in 'Sony PSP - Mod and firmware discussion' started by rob&keri, Feb 14, 2007.

  1. rob&keri

    rob&keri Regular member

    Joined:
    Mar 10, 2004
    Messages:
    161
    Likes Received:
    0
    Trophy Points:
    26
    Now lads don't shoot :)

    I have looked through the forums and most of my questions have been answered but here goes.

    I want to buy a psp to play iso games I have heard dark_Alex's 3.10 OE-A is a good way to go to play these. Are there any verions of the PSP firmware to keep away from or look out for (1.5) seems to be a lot more to buy on ebay than others.

    Hope this hasn't been covered aas I did look

    Rob
     
  2. npdyna

    npdyna Regular member

    Joined:
    Jan 24, 2005
    Messages:
    571
    Likes Received:
    0
    Trophy Points:
    26
    Anything up to 3.03 can be downgrade to 1.5, and then upgraded to the custom firmware.

    I'm not sure what prices for 1.5 PSPs are like on ebay these days, are they more expensive than other ones you've seen? Getting a 1.5 saves you the hassle of downgrading, but it's not worth it if its extra money as it's a relatively easy process.

     
  3. rob&keri

    rob&keri Regular member

    Joined:
    Mar 10, 2004
    Messages:
    161
    Likes Received:
    0
    Trophy Points:
    26
    Is there a guide for someone like me starting out with a standard PSP, I've got a chipped ps2 with Elf files so have a little idea how to do things but just need pointing in the right direction.

    Cheers
    rob
     
  4. rob&keri

    rob&keri Regular member

    Joined:
    Mar 10, 2004
    Messages:
    161
    Likes Received:
    0
    Trophy Points:
    26
    I have done another search and got myself confused really need a list of software and hardware I have to get so I will have a PSP that can play ISO's.

    Also what is an 'unpatched GTA LCS'? and why does someone want a 360 for it?

    Rob
     
  5. yohex

    yohex Guest

    An unpatched Grand Theft Auto Liberty Stories, is used to downgrade psp with version 2.81 to 3.03, thats why it is special, to know if its unpatched it would give you the 2.00 update instead of the 2.60 I think, and nobody would trade in a 360 for it, the dude was just an idiot. Also all you need is a PSP and GTA:LS if you have 2.81 - 3.03, to downgrade and upgrade to custo FW.

    And if you want get the mod chip for the psp so you can't "brick" it.
     
    Last edited by a moderator: Feb 16, 2007
  6. Kazangwa

    Kazangwa Regular member

    Joined:
    Jul 9, 2006
    Messages:
    513
    Likes Received:
    0
    Trophy Points:
    26
    Rockstar's original release of Grand Theft Auto: Liberty City Stories had capabilities to run homebrew due to a savegame exploit. But, they re-released it so that was patched. To access most things, you have to find an unpatched version.
     
  7. yohex

    yohex Guest


    You learn something new everyday, thanks. I thought you'd be an afterdawn addict by now.
     
  8. Eisherz

    Eisherz Active member

    Joined:
    Nov 28, 2006
    Messages:
    2,828
    Likes Received:
    33
    Trophy Points:
    78
    The modchip + installing it costs more than a new PSP and you have to find a shop that still installs it. Also with a custom firmwar, there is no real point in being afraid of a partial brick anymore. It's quite hard to get a brick that bad that you can't even access recovery menue anymore.
     
  9. rob&keri

    rob&keri Regular member

    Joined:
    Mar 10, 2004
    Messages:
    161
    Likes Received:
    0
    Trophy Points:
    26
    OK, is there a guide on here that I can follow? I sort of understand you need to downgrade the firmware then update it? and then get some software that allows you to play iso's, is this right?

    Rob
     
  10. yohex

    yohex Guest

    Yes, Downgrade and upgrade to the custom software, as for guides what FW is your psp that you bought?
     
  11. rob&keri

    rob&keri Regular member

    Joined:
    Mar 10, 2004
    Messages:
    161
    Likes Received:
    0
    Trophy Points:
    26
    I haven't got one yet, was trying to find the one with the best firmware so I could do it myself. The ones with 1.5 firmware seem to go for more on ebay.

    Rob
     
  12. Eisherz

    Eisherz Active member

    Joined:
    Nov 28, 2006
    Messages:
    2,828
    Likes Received:
    33
    Trophy Points:
    78
    Firmware 1.5 is the one you have to downgrade to. Easiest downgrade would be from 2.00, then 2.71 and last 3.03. I don't have any experience with downgrading from 2.80, so I can't tell if that downgrade is easy or not. For downgrading 3.03 you need an unpatched version of GTA Liberty City Stories, you normally can't get it in stores anymore, look at ebay for the price.
     

Share This Page