1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

newbish question - help me out

Discussion in 'Sony PSP - Mod and firmware discussion' started by hunnis, May 2, 2007.

  1. hunnis

    hunnis Member

    Joined:
    Jul 7, 2006
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    11
    Ok, so I'm about to get a psp. I can get a new one or one that already has 1.5 firmware. I assume 1.5 firmware would be best. Now, the main thing I want to do is play .isos on the psp. So if I get the one with 1.5 firmware, what do I have to do, just upgrade to a custom firmware? I have modded xboxes, ps2s, and ds lites before, but what are my chances of bricking the psp? Any help is greatly appreciated.
     
  2. xFlamex

    xFlamex Regular member

    Joined:
    Apr 9, 2007
    Messages:
    122
    Likes Received:
    0
    Trophy Points:
    26
    yeah you just upgrade to the 3.30oe so you can still play your regular games you know what to do with your .iso files?

    and 95% of people on the forums have custom upgraded from 1.5 so they can all vouch for the upgrades and stuff...
     
  3. hunnis

    hunnis Member

    Joined:
    Jul 7, 2006
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    11
    Thanks. And that is a pretty simple process? I have seen there is basically a program you run from the memory stick and it does it pretty much automatically? Then I can run .isos and original games? Also, I don't exactly know how to run the .isos on a psp, but I assume I can figure that out. I just don't want to brick anything with the firmware....
     
  4. xFlamex

    xFlamex Regular member

    Joined:
    Apr 9, 2007
    Messages:
    122
    Likes Received:
    0
    Trophy Points:
    26
    there are that many tutorials on here you can not get lost or anything just use the search feature...
     
  5. hunnis

    hunnis Member

    Joined:
    Jul 7, 2006
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    11
    Actually, one more question. So if I just use the 3.40 oea installer, I should be set?
     
    Last edited: May 2, 2007
  6. Almakra

    Almakra Guest

    there are loads of guides on here - do your research first because yes you can brick your psp really quite easily if you make a mistake. there are posts here daily where people have not read the guides properly or missed out something.
    there is more than enough information around to get it right.

    RESEARCH - is the key word.

    my advice to you is to NOT upgrade your sony official firmware to anything higher than 3.xx as there are no downgraders yet available for fw's higher than this.
    i, foolishly and without researching first, upgraded to 3.11 thinking that it was the latest thing and that i should have it.
    WRONG
    now im stuck with it until someone creates a downgrader :-(

    just be careful - homebrew rules on all consoles

    as for whether to buy new or second hand - i would advise to buy one new (making sure the fw is below 3.xx) and also make sure that the store you get it from has a returns policy. then if it bricks you can take it back and say it just stopped working. just in case!

     
  7. hunnis

    hunnis Member

    Joined:
    Jul 7, 2006
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    11
    I appreciate the helpful words, but I did read through a lot on this site, and it's all very sporadic. I figured it would be easier to ask. If I understand it right, the 3.40 oea custom firmware is the best. If I use the auto-installer I think I will be fine.
     

Share This Page