1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

No Audio In .AVI Sample

Discussion in 'Video to DVD' started by Flibber, Jul 18, 2007.

  1. Flibber

    Flibber Member

    Joined:
    Jun 18, 2007
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    11
    This leads me to believe there is no audio in the movie file. I'd like to post a screenshot because of all the info in GSpot, but I can give the highlights here...

    (SVCD2DVD 2.0 Stats)

    Size : 14.1 mb
    Video Type : Mpeg4
    TV Standard : NTSC (Film)
    Resolution : 640x352
    Total Bitrate: 1845 kbps
    Audio Type : AC3
    Sample Rate : 48,000Khz
    Audio Bitrate: 448 kbps
    Duration : 00:01:04.4

    (GSpot 2.70a Stats)

    Sample.avi
    Size : 14.1 MB (14,528 KB / 14,876,672 bytes)

    [Container]
    File Length Correct
    OpenDML (AVI v2.0)
    Interleave: 1 vid frame (42 ms), preload=480
    Audio frames: Split across interleaves
    Video: 10.6 MB (75.16%)
    Audio: 3.44 MB (24.28%)
    AVI Overhead: 82.4 KB (0.57%)

    [User Data/Metadata]
    [ISFT] VirtualDubMod 1.5.4.1 (build 2178/release)
    [IAS1] English
    [JUNK] VirtualDubMod build 2178/release
    [USER] XviD0037

    [Audio]
    0x2000 (Dolby AC3) AC3...{CBR}
    48000Hz 448 kb/s tot , 6 chnls (3/2 .1)
    1 codec installed

    [Video c,S]
    Codec: XVID
    Name: XviD 1.0.3
    {MPG4}
    {PVOP}

    [Video t]
    Avg/Max Keyframe (I-frame) Distance: 140.5 avg / 240 max
    Duration: 1:04.481
    Frame Count: 1,546
    Avg Bitrate: 1387
    Frame Quality: 0.257
    Pics/s: 23.976
    Frames/s: 23.976

    [Video d]
    pic (w x 640x352)
    sar: 1.818 (20:11)
    par: 1.000 (1:1)
    dar: 1.818 (20:11)

    [Proposed Codec Solutions and Tests]

    {GSpot Vid 1 & 2}
    (Src)-->>--(A)-->[AVI Splitter]>--(B)-->[XviD MPEG-4 Video Decoder ]>--(C)-->[Video Renderer ]
    Video Render OK. Use [3] to play
    (Src)-->>--(A)-->[AVI Splitter]>--(B)-->[DivX Decoder Filter ]>--(C)-->[Video Renderer ]
    Failed to connect Output pin 0x00931c8c ("Stream 00") on AVI Splitter to input pin 0x009369fc ("XForm In") on filter 0x020fcd76 ("DivX Decoder Filter").ConnectDirect() failed. Error: 0x80040207: [unknown]
    (Src)-->>--(A)-->[AVI Splitter]>--(B)-->[VFW:XviD MPEG-4 Codec ]>--(C)-->[Video Renderer ]
    Video Render OK. Use [3] to play

    {GSpot Aud 1 & 2}
    (Src)-->>--(A)-->[AVI Splitter ]>--(B)-->[InterVideo Audio Decoder ]>--(C)-->[Default DirectSound Device ]
    Failed to connect Output pin 0x0093657c ("Stream 01") on AVI Splitter to input pin 0x0094301c ("XForm In") on filter 0x02129758 ("InterVideo Audio Decoder").ConnectDirect() failed. Error: 0x80040207: [unknown]
    (Src)-->>--(A)-->[AVI Splitter ]>--(B)-->[Nero Digital Audio Decoder ]>--(C)-->[Default DirectSound Device ]
    Failed to create instance of Nero Digital Audio Decoder. CoCreateInstance() failed. Error: 0x80004005: [unknown]

    {MS A/V}
    Partial Render Failure: Following is the error reported by DirectShow:
    0x00040242: [unknown]
    More specifically, video could be rendered, but the audio could not:
    (Src)-->>--(A)-->[AVI Splitter]>--(B)-->[XviD MPEG-4 Video Decoder ]>--(C)-->[Video Renderer ]

    That's it folks, hope it gives a clue why no audio other than it has "failed".

    CG
     
  2. attar

    attar Senior member

    Joined:
    Jun 17, 2005
    Messages:
    11,509
    Likes Received:
    29
    Trophy Points:
    128
    If you Demux the AC3 from the original AVI then the likes of VLC should be able to play it ok (unless it's corrupted).
    I see it's a multiple stream and VirtualDubMod only selects one?

    http://www.alexander-noe.com/video/amg/

    Load AVI,highlight,generate data source from file, then right click on the Audio and extract binary.
     
  3. Flibber

    Flibber Member

    Joined:
    Jun 18, 2007
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    11
    It turned out I didn't have the AC3 codec installed or it was corrupted...

    I only assumed that the 20 or so editing programs I have should have at least come with all the codecs I would need...

    Thanks for the quick reply!

    CG
     

Share This Page