1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

No audio while playing DVD's & DVD Files

Discussion in 'DVD±R for advanced users' started by Hosay, Aug 18, 2007.

  1. Hosay

    Hosay Member

    Joined:
    Jun 10, 2005
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    11
    Ok so i use Magic DVD Ripper to rip movie DVD's to my HDD, i then use Nero to burn them and watch on my Standalone DVD Player, works great.

    My problem is that when i play the DVD files on my puter using VLC media player 0.8.6a or Cyberlink's PowerDVD7 or Win Media Player11 or any other player, all i hear is the background music and not the vocals, so when people talk i can't hear them, only the background music of the film, i also have the same problem when i watch the original DVD, again no vocals only background music.

    I have 5.1 surround and it doesn't matter if i put it on 2.0 stereo or 5.1 surround, i still can't hear the vocals.

    Opening AC3 filter, going to the Mixer tab and adjusting the settings to adjust the voice doesn't help neither.

    I don't have a problem hearing the avi's, wmv's, mpeg's, etc ... my only problems are with the dvd's and dvd movie files that i ripped onto my HDD.

    Yes, i have the latest K-Lite Codec Pack, and Yes, i've also updated to my latest soundcard drivers.

    So anyone has any ideas how to fix this? :(

    Thanks :)
     
    Last edited: Aug 19, 2007
  2. creaky

    creaky Moderator Staff Member

    Joined:
    Jan 14, 2005
    Messages:
    31,683
    Likes Received:
    1
    Trophy Points:
    96
    First of all i'm totally without a clue as to Magic DVD Ripper - never heard of it..
    i wonder if it's worth trying DVDFab HD Decrypter (free) - http://www.dvdfab.com/free.htm and see if you get any better progress. I'm probably completely off at a tangent here but it's worth a go, certainly easier than troubleshooting the audio problem (for now anyways)..

    i could understand no audio at all as i have that on one of my pc's now and then, but to have only music and no audio that is very odd. I've previously found VLC player to be quite good for stuff like this, it seems quite flexible in it's audio tickboxes. I use k-lite's mega codec pack myself and find it to be very good so don't think it's down to that.. are you sure it's not Magic Ripper at fault (though i do see you say the original dvd's exhibit the same problem). As i say, try DVDFab and see if it magically works, at least it's quite quick to check via DVDFab
     
    Last edited: Aug 19, 2007
  3. Hosay

    Hosay Member

    Joined:
    Jun 10, 2005
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    11
    Thank You Creaky, i will try what you suggested, i will also uninstall my k-lite codecs and see if they have newer versions :)
     
  4. Rich4677

    Rich4677 Member

    Joined:
    Aug 26, 2007
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    11
    Hosay,

    Did you ever figure out your problem? I am having the exact same one, and I am going crazy downloading different codecs to see if they will work. I do have codec detective, and it is telling me that my WMplug codec is broken, but I don't know for sure if this is the problem or how to fix it.
     
  5. creaky

    creaky Moderator Staff Member

    Joined:
    Jan 14, 2005
    Messages:
    31,683
    Likes Received:
    1
    Trophy Points:
    96

Share This Page