1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

No HDMI Audio when plugged through HDMI switch

Discussion in 'Home Theater PC' started by bobiroc, Sep 26, 2012.

  1. bobiroc

    bobiroc Member

    Joined:
    Jun 27, 2003
    Messages:
    95
    Likes Received:
    0
    Trophy Points:
    16
    Ok here is one that has been stumping me for a couple days. My work has this fancy set up in a couple meeting rooms where mulitple TVs and a Projector are connected to a system that can switch and distribute video and audio. The problem I am having is that when I try to connect a HDMI computer to this setup it will pass video but not audio. I usually get an error that the tone cannot be played or the device is in use by another program. Now If I take the same computers and connect directly to the TVs or projector the audio plays fine so I am thinking it has something to do with the switching management. I have tried my personal Laptop that has an AMD GPU with HDMI and also a computer from work with a AMD Radeon card installed with HDMI.

    Now this is where it gets really interesting, when I take a work laptop with Intel Integrated Graphics with HDMI both Video and sound work perfectly. I have not tried with an NVidia based card as I do not have one at my disposal but thought about getting one for the desktop computer they want to use.

    I was hoping that there was some way I can just force the computers that do not work to pass the audio no matter what but I have tried various levels of drivers and nothing.
     

Share This Page