1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

No Power need help!!!

Discussion in 'PS2' started by bassman68, Jul 30, 2007.

  1. bassman68

    bassman68 Member

    Joined:
    Aug 8, 2005
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    11
    I tried posting this in the other forum but I haven't had any responses so I am going to post here.

    I purchased the Dsm4 ezi for my ps2. I took everything apart and installed it just like the directions stated. I put everything back together. I tried to turn it on and no power. I rechecked everything and it appeared that I had tried to put a screw through the eject reset cable. It didn't rip it but it put an indention in it. Anyway, I eventually took the mod chip off and reconnected everything. Still no power. I ordered a new cable today that got damaged. Could this be the cause of no power? I looked at the main fuse but It is ceramic. I don't see how it even comes off to replace or check. Can anyone give me some help please?
     
  2. bassman68

    bassman68 Member

    Joined:
    Aug 8, 2005
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    11
    Ok. I thought I would just answer my question myself. I tested the mother board and I think all of the fuses were good. One of them might be bad but I couldn't tell. It was the one labeled PS1. Anyway, I have left a message with ps2parts.com about how they charge to fix it and possible see if they can install that chip for me if it is not damaged.
    I would try to fix that PS1 but it looks small and I can't seem to find any directions on how to go about replacing it.
     

Share This Page