1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

non-permanent subtitles not showing up

Discussion in 'Convert DVD to another format' started by Priest, Nov 23, 2002.

  1. Priest

    Priest Member

    Joined:
    May 8, 2002
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    11
    I was ripping Red Dawn. In a few select clips in the movie Russians are speaking and there are english subtitles just in those clips when the DVD is playing . I thought the subtitles were encoded in the Vobs and would show up in my Divx rip but they don't. I had the same problem with Black Hawk Down. Anyone have ANY clue as to why it doesn't show up in Divx rip?
     
  2. chrisw

    chrisw Member

    Joined:
    Nov 25, 2002
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    16
    I have no idea as to why, other than the theory that the encoded subtitle files on the DVD contain instructions to the DVD software to show these particular subtitles regardless of whether you have subtitles turned on or not.

    When I ripped Star Wars Episode Two, there are, like in your film, sections where the characters speak in foreign languages... So, to get around this, I installed DirectVobSub (the filter version of VobSub that installs and loads whenever you load a DivX into WiMP and displays the subtitles). Then, I used SubRip to rip the subtitles and save them to an .srt file. I THEN opened the .srt file in my text editor (notepad baby yeah) and removed ALL the entries apart from the bits where the characters were talking in foreign languages.

    Now, when SubRip saves the subtitles to the .srt file it puts a number on the beginning of each subtitle section. It's at the beginning of the first line of each subtitle section... You'll see what I mean when you see the .srt file's contents for yourself. So, once you've removed all the other entries chances are you'll be left with subtitle entries that have numbers that don't follow in sequence (e.g. 2, 39, 148, 327, instead of 1, 2, 3, 4 etc). You'll have to renumber all the subtitle entries in the .srt file and then re-save the file to make the subtitles show correctly.


    Don't forget to name the .srt file exactly as the avi file is named... So if your avi is called "Red Dawn.avi" then your .srt file will need to be called "Red Dawn.srt" for DirectVobSub to pick it up. If it still doesn't pick it up properly, click on the green arrow-like icon that'll have appeared in your taskbar when you opened the avi file, right-click on it, choose the DirectVobSub Filter options applet and choose the .srt file using the Choose Subtitles option.


    Phew. What a long-winded explanation.


    If you don't understand what I mean exactly, then just do it and follow this guide through as you go - you'll get it then.


    Hope this helps,
    Christopher Woods.
     
  3. chrisw

    chrisw Member

    Joined:
    Nov 25, 2002
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    16

Share This Page