1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Notepad.com infection aftermath: help needed!

Discussion in 'All other topics' started by Rueful, Dec 10, 2004.

  1. Rueful

    Rueful Guest

    A week or so ago, my laptop picked up notepad.com -- ring any bells with anyone who may’ve had a similar experience?? Anyway. Using Hijack This and sundry clean-up programs I got rid of the damn thing. But. . .

    Seems like I’ve snafu’d my Internet Explorer in doing so. The problem became apparent the other day when it proved impossible to save an eBay (UK) auction page. So I clicked ‘view source’ to see the page in text form and then save as htm. . . but Notepad refused to open. Instead, a small error message appeared with a red cross mark and a warning: incorrect parameter.

    Ah. Thinking it might be something connected with eBay, I then tried using ‘view source’ on other web pages. But either the earlier, simple message appeared or a new, black Command Line window suddenly popped up headed C:\WINDOWS\System32\notepad.pif. Beneath that window, an error message headed “16 bit MS-SOS Subsystem” warned:

    C:\WINDOWS\SYSTEM 32\notepad.pif
    C:\WINDOWS\SYSTEM 32\AUTOEXEC.NT
    The system file is not suitable for running MS-DOS and Microsoft Windows applications. Choose ‘close’ to terminate the application.
    Beneath the message are two buttons – ‘close’, and ‘ignore’. Pressing ‘ignore’ simply clears the warning but doesn’t take me any nearer to accessing Notepad.

    A check of my Windows System 32 directory – with all hidden files revealed -- shows no sign of anything called ‘notepad.pif’, so I’m baffled as to what the warning is referring to. Thinking that the Microsoft application itself might be damaged, I downloaded a new copy and installed that in Windows and Win\System 32. Then I went back to Start / Programs / Notepad and clicked on the short cut and bingo, Notepad opened OK.

    BUT. . . I still can’t get it to open when using Internet Explorer’s “view source”. As noted, obviously I’ve done something wrong, somewhere, and feel pretty stupid about it (though if there’d not been scum around with notepad-com it would never have happened).

    Oh, final point. Having inadvertently allowed the PC to pick up the damn thing a raft of infections --caused by me being in such a hurry one day that I hit the wrong button in ZoneAlarm and allowed a permission for something instead of denying it – I cleared them all out but then kept having to contend AVG pointing to the presence of a dialler in the System Restore volume – which I can’t access.

    Running AVG didn’t, in fact, find it, nor did SpyBot or Stinger or AdAware SE. So I took a friend’s advice and cancelled ‘System Restore’ yesterday . . . and now, although the dialer warning no longer flashes up, I have no roll-back point available to get around this Notepad problem (well, assuming it would).

    Finally. . . I’m not even sure my earlier cleansing exercise has been a success anyway: ZoneAlarm now keeps asking me if I wish to allow “Generic Host Process for Win32 Services to accept connections from the Internet: Source IP 194.74.65.87 DNS, application: svchost.exe, version: 5.1.2600.0 (xpclient 010817-1148)”. I don’t recollect anything called svchost.exe looking for connection permission before so I keep refusing it – but maybe it’s that refusal which, somehow, has some bearing on IE6’s failure to activate/access Notepad?? (Hmm, probably not, but. . .)

    Apologies for length of this note, but if anyone has any ideas, that’d be greatly appreciated! (I’m running Windows XP Home and would like to switch ‘System Restore’ back on but don’t know if that’s wise in view of the unresolved Notepad problem).


     
  2. CJC

    CJC Regular member

    Joined:
    Aug 23, 2004
    Messages:
    600
    Likes Received:
    1
    Trophy Points:
    26
    Hey

    Have a read of the first post of this thread:
    http://forums.afterdawn.com/thread_view.cfm/128251

    And

    Click on start, then go to Run.. now time in CMD

    Now it should bring up a black box with something like C:\Documents and Settings\Username\>

    Now u have to make sure your windows XP disc is in there

    Then type the following (D: being your CD-ROM drive, if its E: change all the D:'s to E:'s)

    expand D:\i386\config.nt_ c:\windows\system32\config.nt
    (PRESS ENTER)
    expand D:\i386\autoexec.nt_ c:\windows\system32\autoexec.nt
    (PRESS ENTER)
    expand D:\i386\command.co_ c:\windows\system32\command.com
    (PRESS ENTER)
    exit
    (PRESS ENTER)

    Then restart your comptuer and try the program again.

    For the 16bit subsystem error

    (http://forums.afterdawn.com/thread_view.cfm/2/117428)

    See if that helps and post back.

    CJC
     
  3. Rueful

    Rueful Guest

    CJC -- I'm very grateful to you because this has done the trick. I followed your guidance with my XP disk in place and everything's working fine again. Whew! It was so good of you to ride to the rescue so promptly; thanks seem a bit inadequate but, well, THANKS!!!
     
  4. CJC

    CJC Regular member

    Joined:
    Aug 23, 2004
    Messages:
    600
    Likes Received:
    1
    Trophy Points:
    26
    Thanks is always great to hear from people you help out, you realize people appreciate your help :) but some people just get help and run, not even help :-(

    Glad it helped you out.

    CJC
     

Share This Page