1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Ok just bought a psp with 1.5 firmware...

Discussion in 'Sony PSP - Mod and firmware discussion' started by pdf0791, May 28, 2007.

  1. pdf0791

    pdf0791 Guest

    Should I keep it 1.5 or upgrade to any of the custom firmwares?

    And if so, which firmware do you recommend?

    Thanks
     
  2. 1OFDEM

    1OFDEM Regular member

    Joined:
    May 27, 2007
    Messages:
    168
    Likes Received:
    0
    Trophy Points:
    26
    Google "dark alex" and click on the first website that appears. The latest version is 3.40 OE-A. Personally, I use 3.03 OE-C, and I have SNES, GENESIS, PS1, and N64 emulators working near perfectly (with the exception of N64).
     
  3. PeaInAPod

    PeaInAPod Active member

    Joined:
    Nov 28, 2005
    Messages:
    3,065
    Likes Received:
    0
    Trophy Points:
    66
    Not to discredit you 1OFDEM but I would personally suggest the use of a Winstaller for any of the custom firmwares as it is a lot easier and more reliable. There is also one for 3.40 OE-A should you want that custom firmware pdf0791.

    3.03 OE-C:
    http://rapidshare.com/files/24380814/3.03_OE-C_Winstaller.exe

    3.40 OE-A:
    http://www.psp-hacks.com/download.php?id=1134

    1.50 Recovery Mode Files:
    http://fs02n1.sendspace.com/dl/c0b2...04d434690/454l5j/1.50 Recovery Winstaller.exe

    And here is a link to, as far as I know, all of the DarkAlex sites....
    Exophase.com , Lan.st , Dax.st , Downgrader.lan.st , ElOtroLado.net , PspGen , Ps2dev.org , Moonlight.lan.st , dax.lan.st
     
    Last edited: May 28, 2007
  4. johnc1234

    johnc1234 Regular member

    Joined:
    Nov 29, 2006
    Messages:
    706
    Likes Received:
    0
    Trophy Points:
    26
    great choice mate. the one disadvantage is no ps3 remote play : (
     
  5. pdf0791

    pdf0791 Guest

    thanks for your help PeaInAPod.
     
  6. K3itaro

    K3itaro Member

    Joined:
    Oct 28, 2006
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    11
    I've softmodded my Xbox and PS2 (fat), firmware upgraded my Xbox360 and purchased a flashcart for my Nintendo DS Lite but I'm new to the PSP (haven't bought one yet) and this firmware version malarky has me stumped.

    Is it still recommended to look for one that comes with 1.5? Or is any firmware from Sony downgradable now?

    The reason I ask is I see all these threads at the top of this forum with 3.3 this and 3.4 that in the title. I'm wondering if it means that if I was to buy one that comes with Sony's 3.3 or 3.4 then can I still change it to one of Dark-Alex's?
     
  7. PeaInAPod

    PeaInAPod Active member

    Joined:
    Nov 28, 2005
    Messages:
    3,065
    Likes Received:
    0
    Trophy Points:
    66
    For the PSP any PSP up to version 3.03 can be downgraded. Now however any PSP with firmware version 2.81 to 3.03 needs a specific version of Grand Theft Auto: Liberty City Stories to allow a downgrade. Any PSP at firmware version 2.80 or below can be downgraded without GTA:LCS. And although not as important, if a PSP w/ firmware ver. 1.5 is found at a good price it is still considered a lucky find so to speak.
     
  8. K3itaro

    K3itaro Member

    Joined:
    Oct 28, 2006
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    11
    Thanks PeaInAPod. I wish they'd add this seemingly basic piece of info to the "*The Motherload of PSP Guides*" sticky thread at the top of this forum.
     
  9. johnc1234

    johnc1234 Regular member

    Joined:
    Nov 29, 2006
    Messages:
    706
    Likes Received:
    0
    Trophy Points:
    26
    yer, like peaInAPod says I wouldnt wanna downgrade a 1.5, i'd up it to dark alex firmware. XD
     

Share This Page