1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

philips dvp642, how do i get it to play subs?

Discussion in 'DVD players' started by chahal4, Jan 7, 2005.

  1. chahal4

    chahal4 Member

    Joined:
    Dec 19, 2004
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    16
    how do i get the films to play subs, so like .srt or .sub.

    is it possible?
     
  2. Kangasama

    Kangasama Member

    Joined:
    Jan 3, 2005
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    11
    Drew2k posted this in another thread. Just sharing the info .. Hope this helps...
    --------------------------
    Drew2k said:

    Check your User manual for a loose page (addendum) on how to use subtitles with DIVX. It was at the end of my manual, but in case you don't have the addendum, the steps are:

    1. Highlihght the external subtitle filename
    2. Press SUBTITLE on the remote - should see DIVX SUBTITLE SELECTED on screen.
    3. Highlight the movie and press OK to play it using the previously selected subtitle.
    4. During playback, press SUBTITLE on the remote to select the avaiable font: subtitle 1/1, encoding latin 1, encoding latin 2, encoding latin cyrillic, subtitle off.

    This is my first post here - lots of good info all around, so I hope I helped!

    Drew
    --------------------------------
     
  3. acid63

    acid63 Guest

    I do have a Philips DVP 642/17 player and I was struggling to make it show the subtitles. I have read several forums and several threads which were related to subtitle problem. I have tried vobsup (xxx.sub.cc.raw/idx/sub), subrip (.srt), and subtitle workshop to create .srt files. None of them has worked. Here is the comprehensive summary of suggested solutions that I have found and compiled. I have found one solution as the combination of two methods.

    1) Upgrading firmware. I have successfully upgraded my firm to the latest version (from 0531 to 1109. This upgrade did not solve my problem. I did get the little green like box around .srt file as a text. I couldn’t choose it as divx subtitle. I always get the hand on the upper left corner. Similarly, .sub files from subrip appeared as, mpeg2 file and remote did not work to select them as subtitles.
    2) Another method suggested was the following: First highlight the subtitle file and do not press OK. Instead, press subtitle button on the remote. It should say “divx sub title selected” on the screen, then select the movie file and play it. I tried it (firmware version 1109) and it did not work.
    3) Rename the subtitle file to contain less than 12 characters and then the player will recognize it. I did not try this alone. I tried a combination with solution #4 below.
    4) Another solution was to put all items, movie and subtitles, in a folder and burn it to CD.

    I tried solutions #2 and #4 as combined. I created a folder and named it as the movie name. I have put the subtitle file in that folder. The subtitle file was named exactly as the movie file. I have created another subtitle file and named it as subtitle.srt. I put the CD into the player and played the movie. No subtitle appeared when I pressed the subtitle button on the remote. I got the stop hand. I stopped the movie and went to menu. Opened the folder that I have created and I have applied trick #2. I was able to select the each individual subtitle and I got the message “Divx sub title selected” in each case. Each subtitle file showed up when I am in the play mode. On the other hand, when I applied the trick to get a gray background by pressing menu and when movie plays, then hitting the system menu trick twice did not work. I got the hand again. On the other hand, first selecting the subtitle file as described and then playing the movie by pressing menu button and pressing the system menu twice on the remote after the first frame did the trick. Renaming the file with less than 12 characters or naming it exactly the same way with the movie file did not matter much. Both files worked. In my second attempt, I created a folder and gave it an arbitrary name. I put the subtitle file and the movie file into this folder. Subtitle file was named exactly as the movie file. Applying #2 tricks was successful. I got the subtitles. I use Nero burning software. Subtitle files are .srt files created with subrip and saved as ASCI-II (text file) after editing with MS Word. Later, I opened them with subtitle workshop and did the file splitting and time adjustment. I saved them as subrip .srt files. I do not think that it would make any difference whether you create .srt files either with subrip or subtitle workshop. Latter is convenient and easy to use.
    Third experiment was to test idx/sub subtitles. I burnt a CD from the movie and the subtitle files (cc.sub.raw/idx/sub). Subtitle files were named exactly as the movie files. Player recognized only one file as mpeg 2 and I did not get any luck. I have created another CD from the same subtitle files and the movie. This time I have put them into a folder and burnt the CD. Subtitles did not work. The subtitle file was again recognized as mpeg 2. I did find some information how to convert subrip files to .srt. Below is the two ways explained. In my opinion, the player is not recognizing .idx file which is necessary to time stamp and play the OCR image sub file.


    1) In subrip select Open VOB, Open IFO and select the .idx. Complete the optical recognition and save the file as .srt.
    2) Look in the directory where VobSub is installed for an .exe file which is called "Subresync." Double-click that to run the program, and you can use Subresync to convert your sub-idx files to srt format.

    I have converted the subtitles to .srt by applying the method 1. I created a folder and I have named it as I wish. I named the subtitle file as I wish. I put the movie and the subtitle file into this folder and burn it to CD with Nero. It worked.

    Anyway, it was a challenge for me to get this player to show subtitles. I have seen several people suffering from the same problem. I hope this review will help. I also thank all of the people who shared their experiences and solutions via different forums and threads. I have solved my problem combining methods 2 and 4. Although, I did not test these in the old firmware, I believe it will not make any difference. Here is the summary of the methods that worked for me with Philips DVP 642/17 firmware version 1109.

    1) Create a folder. Name is not important.
    2) Put your movie and subtitle file (.srt) into this folder.
    3) Burn the folder to CD. I used Nero with default settings.
    4) Put the CD into the player.
    5) When disk loads, select the folder and open it. If movie starts immediately, stop it and go to root menu. Find folder and open it.
    6) Select the subtitle file. Do not hit OK. Instead press subtitle button on the remote.
    7) Make sure you will see “DIVX sub title selected”.
    8) Then select movie and then hit OK or PLAY.
    9) You can choose three different subtitle settings by pressing subtitle button and also you can turn subtitles off by pressing several times till subtitle off option appears on the display.
    10) If you want to apply change the background to gray setting, then, after item 7 do the following. Select the movie and press menu (not the system menu). Wait till wait and reading file messages disappear and then press system menu button twice after the appearance of the first frame.
     
  4. p200002

    p200002 Member

    Joined:
    Dec 22, 2003
    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    16
    If you have idx+sub type subtitle, use vobsub's subresync. You need to manually map each graphic letter into text letter. I converted several idx+subs into srt and they play well on my 642.
     
  5. chahal4

    chahal4 Member

    Joined:
    Dec 19, 2004
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    16
    how do i "manually map each graphic letter into text letter"?
     
  6. p200002

    p200002 Member

    Joined:
    Dec 22, 2003
    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    16
    if program shows a graphic representation of T then you enter T. There are only 26 english characters X2 + coma, colon, ! etc. If your sub is in a different language, i.e. Chinese, forget philips.
     
  7. chahal4

    chahal4 Member

    Joined:
    Dec 19, 2004
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    16
    any guides on the net on how to do that?
     
  8. p200002

    p200002 Member

    Joined:
    Dec 22, 2003
    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    16
    You don't need a guide. Install vobsub, then run subresync, open .sub file, save as .srt, start mapping.
     
  9. cska133

    cska133 Member

    Joined:
    Jan 26, 2005
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    11
    hi gays

    is this true:))) do you mean you have found out how to play AVI/DivX Videos WITH SUBTITELS(!!!) on my domestic DVD player Station??...where the subtitles are saparate files and there are playable on the DVD Player???!!!

    is that wright? please confirm if yes and tell me exactly whaT to do to play my Subtitles with my AVIs on the DVD Station....

    thanks
     
  10. chahal4

    chahal4 Member

    Joined:
    Dec 19, 2004
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    16
    so the 642 only plays .srt? no .sub? im always gona have to make em .srt?
     
  11. cska133

    cska133 Member

    Joined:
    Jan 26, 2005
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    11
    no answer :-///// ????????
     
  12. p200002

    p200002 Member

    Joined:
    Dec 22, 2003
    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    16
    1. This question has been asked before in the forum.
    2. Your philips dvp642 user manual has a supplemental papper that tells you how to play subtitle.
     
  13. chahal4

    chahal4 Member

    Joined:
    Dec 19, 2004
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    16
    hey, p2000002-chill

    nd cska133, not any dvdplayer. this is the philips dvp642 with DivX playback, if thats the ne you got, then ye.

    and thx every1 for their help, got em workin.
     
  14. cska133

    cska133 Member

    Joined:
    Jan 26, 2005
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    11
    my divx player is not Phillips, i have JVC.....so i want to know if there is any possibility for other players to play subtitles and how?
     
  15. aerogurl

    aerogurl Member

    Joined:
    Feb 2, 2005
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    11
    I am a new owner of the dvp-642/37 and I am also having problems with the subtitles.

    [bold] In response to what "acid63" had to say...[/bold] I have older divx movies and they are burned with the .srt and the .avi in the same folder, HOWEVER, it is the root folder. I did not make a folder on the CD only drag and dropped the files over into the compilation. Does this matter? I've done all the other stuff, highlight the .srt file, press ok on the movie, and when i am watching the movie, i see where it says latin 1, and all that.. whereas if I didnt select the subtitle as previously mentioned I just got the little white hand. I see that its trying to work. It is name exactly the same as the .avi file.
    What am I doing wrong?

    Thanks for any help....
     
  16. Zisguy1

    Zisguy1 Member

    Joined:
    Feb 10, 2005
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    11
    When you highlight the .srt file on the menu, don't press OK on it. Press the subtitles button. Now highlight the main movie and press OK. When it starts playing, press the subtitles button again to turn them on.

    If this doesn't work, your .srt file may not be in plain text format. Check it in Windows Notepad, if you see little squares or other characters try opening it in Wordpad and save in "MS-DOS text format."
     
    Last edited: Feb 11, 2005
  17. chahal4

    chahal4 Member

    Joined:
    Dec 19, 2004
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    16
    i save them as "MS-DOS text format" but they still come up as question marks in the menu of the dvd in the player.
     
  18. spyhacker

    spyhacker Member

    Joined:
    Mar 1, 2005
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    11

Share This Page