1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

play games on emulator?

Discussion in 'Sony PSP - Games' started by aldxar, Feb 23, 2007.

  1. aldxar

    aldxar Member

    Joined:
    Nov 21, 2006
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    11
    ok, sorry if this has been asked b4, but it seems i left for holiday, but when i came bak all these psp talks has evolved into somewhat confusing business for me, like all these oec-a/b, or whatever they are being call now which i never heard of before i went on holiday, so my question is now, there was a emulator on the 2.71 psp that allow u to play iso/cso games without downgrading the psp to 1.5, u just run it through ur psp, but now it seem games are going up to 3.10(?) in firmware, so i want to kno if there are any emulator like that for the latest firmware? or emulaotr that run games after 2.71?, thanks for the answers!
     
  2. mrgooey

    mrgooey Regular member

    Joined:
    Nov 5, 2005
    Messages:
    4,058
    Likes Received:
    0
    Trophy Points:
    46
    dev hook is the app that can only run to 3.03 firmware games. To run 3.10 u need Dark Alex new CS which is 3.10 OE. Howver u need to downgrae or put a HEN-D on ur psp.
     
  3. aldxar

    aldxar Member

    Joined:
    Nov 21, 2006
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    11
    so if i dont want to downgrade, jus like when i was using the 2.71 emulator, what exactly do i use? does the 2.71 emulator only play games upto 2.71 firmware btw?
     
    Last edited: Feb 24, 2007
  4. mrgooey

    mrgooey Regular member

    Joined:
    Nov 5, 2005
    Messages:
    4,058
    Likes Received:
    0
    Trophy Points:
    46
    yes it only plays to 2.71. I recommend u should update ur emulator. Or get dev hook, that is the best iso/cso emulator.
     
  5. aldxar

    aldxar Member

    Joined:
    Nov 21, 2006
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    11
    so does it mean i have to downgrade my psp to 1.5? thank you for ur help btw
     
  6. chanman1

    chanman1 Regular member

    Joined:
    Feb 6, 2006
    Messages:
    1,705
    Likes Received:
    0
    Trophy Points:
    46
    it means to use a downgrader to lower ur psp firmware down to 1.5.
     

Share This Page