1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Play time is off, VERY weird problem

Discussion in 'MPEG-1 and MPEG-2 encoding (AVI to DVD)' started by efface, Apr 4, 2005.

  1. efface

    efface Member

    Joined:
    Mar 31, 2005
    Messages:
    43
    Likes Received:
    0
    Trophy Points:
    16
    I combined 3 mpg into 1 mpg, comes out to about 122 minutes in length. Video plays without any glitches what so ever and winamp says the movie is 122 minutes long. When I reencoded the mpg to change the fps for dvd rip, i noticed that the file size seemed right but the video file only plays the first 39 minutes of the movie. It doesn't freeze or anything thats just how long it thinks the movie is.

    Before I had reencoded, I tried opening the file up in TMPGenc to make a dvd (before i remembered i had to fix the fps) and it complained of a GOP error. So I got mpeg2vcr to fix the GOP problem. It went through and fixed it.

    When I played the fixed file....it only played the first 38-39 mins of the whole movie (same problem just thinks thats how long the movie is). So then inside mpeg2vcr I played around with the movie and I noticed that the original mpeg I had showed a play time of 39 mins to mpeg2vcr but the whole movie was there and really more like 122 minutes. I could play the whole movie through, move the slider back and forth through the whole movie, but it still showed a playtime of 39 mins. How would I go about fixing this? Thanks in advance
     
  2. efface

    efface Member

    Joined:
    Mar 31, 2005
    Messages:
    43
    Likes Received:
    0
    Trophy Points:
    16
    anyone? :)
     
  3. rebootjim

    rebootjim Active member

    Joined:
    May 13, 2004
    Messages:
    2,631
    Likes Received:
    0
    Trophy Points:
    66
    What's the finished product going to be? DVD?
    What did you use to join them? Why?
     
  4. efface

    efface Member

    Joined:
    Mar 31, 2005
    Messages:
    43
    Likes Received:
    0
    Trophy Points:
    16
    I believe I used VirtualDub and/or mpeg-vcr. I'm trying to put a movie that was split into 3 pieces, onto dvd. So thats why i am trying to combine them. The only thing I can think of that might be causing this problem is that they were SVCD or VCD and I just took the mpg out and joined them instead of using a SVCD/VCD convertor....but the only flaw in that thought is that the resulting video plays the first 39 mins....and the first file is only 24 mins...so that means the first two joined somewhat right.
     
  5. rebootjim

    rebootjim Active member

    Joined:
    May 13, 2004
    Messages:
    2,631
    Likes Received:
    0
    Trophy Points:
    66
    I would encode the 3 pieces separately, joining them in tmpgenc or mpeg-vcr afterwards.
    Something is happening in the join.
     

Share This Page