1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Playing PSP Games

Discussion in 'Sony PSP - Mod and firmware discussion' started by Faisal937, May 31, 2007.

  1. Faisal937

    Faisal937 Guest

    Hi

    I'm a PSP newbie so be gentle

    I just upgraded my PSP to 3.03 from 2.82 and wanted to know how to copy and play the games over?

    I don't have no DevHook or anything installed

    Thanks in advance
     
  2. mrgooey

    mrgooey Regular member

    Joined:
    Nov 5, 2005
    Messages:
    4,058
    Likes Received:
    0
    Trophy Points:
    46
    3.30 or 3.30 OE?
     
  3. Faisal937

    Faisal937 Guest

    3.03
     
  4. mrgooey

    mrgooey Regular member

    Joined:
    Nov 5, 2005
    Messages:
    4,058
    Likes Received:
    0
    Trophy Points:
    46
    sry ... 3.03 cant play backup games. u have to downgrade the psp to 1.5. If u want to downgrade then click the search button and look for a guide.
     
  5. Faisal937

    Faisal937 Guest

    After i downgrade, do i need to install devhook or anything like that or can i just copy the game file across to the PSP?

    Thanks
     
  6. mrgooey

    mrgooey Regular member

    Joined:
    Nov 5, 2005
    Messages:
    4,058
    Likes Received:
    0
    Trophy Points:
    46
    dev hook or custom firmware
     
  7. Faisal937

    Faisal937 Guest

    Whats the best version of devhook to use?

    I been told that it might be better if i downgrade to 1.5?
     
  8. blackvamp

    blackvamp Regular member

    Joined:
    May 3, 2007
    Messages:
    1,173
    Likes Received:
    0
    Trophy Points:
    46
    You HAVE TO downgrade to 1.5 first. You need to get an unpatched gta : liberty city story with 2.0 update on it. Then go: http://www.noobz.eu/download.html for downgrader
     
  9. Faisal937

    Faisal937 Guest

    Is there any way to do it without vice city?
     
  10. blackvamp

    blackvamp Regular member

    Joined:
    May 3, 2007
    Messages:
    1,173
    Likes Received:
    0
    Trophy Points:
    46
    Nope. And it's liberty city story, not vice city story
     
  11. Faisal937

    Faisal937 Guest

    Will the liberty city psp game tell you on the back of the case if it has a 2.0 update on it?

    Thanks
     
  12. PYF

    PYF Member

    Joined:
    May 14, 2007
    Messages:
    63
    Likes Received:
    0
    Trophy Points:
    16
    Basically...if you go on ebay search for an "Unpatched Liberty City Stories" which has a code of ULES00151 or something like that. After you buy this....you are all set to downgrade to version 1.5. I recommend that you then upgrade to version 3.40 OE-A because you dont have to have devhook to run homebrew stuff.
     
  13. Faisal937

    Faisal937 Guest

    How do i upgrade to 3.40

    Nice one mate
     
  14. PYF

    PYF Member

    Joined:
    May 14, 2007
    Messages:
    63
    Likes Received:
    0
    Trophy Points:
    16
    basically you downgrade to 1.50 first then upgrade easy using some file. PM me and i will send u it after you downgrade.
     
  15. Faisal937

    Faisal937 Guest

    Thanks

    I'll have a look at downgrading it now and see if i can get hold of a copy of GTA
     
  16. PYF

    PYF Member

    Joined:
    May 14, 2007
    Messages:
    63
    Likes Received:
    0
    Trophy Points:
    16
    you do that...make the most out of your psp and use custom firmware.

    :D (buying LCS on ebay is a good idea by the way)
     
  17. Faisal937

    Faisal937 Guest

  18. PYF

    PYF Member

    Joined:
    May 14, 2007
    Messages:
    63
    Likes Received:
    0
    Trophy Points:
    16
    Last edited: Jun 1, 2007
  19. Faisal937

    Faisal937 Guest

    Whats the best way?
    I can just get a copy of GTA and downgrade it to 1.5 and start playing ISO files or do i have to upgrade to 3.40 0E-A
     
  20. PYF

    PYF Member

    Joined:
    May 14, 2007
    Messages:
    63
    Likes Received:
    0
    Trophy Points:
    16
    Basically, in the past everyone loved 1.50 including me. However in order to run iso files or homebrew apps you need Devhook or Fastloader. However, custom firmware lets you run iso files and other stuff without programs like devhook you can play them straight from the xmd (sony start up screen thingy). 3.40 OE-A is the way to go, trust me.

    EDIT: You have to downgrade to 1.50 before you upgrade to 3.40 OE-A
    by the way because you cant dowgrade from 3.03 to 3.40 OE-A straight away.
     
    Last edited: Jun 1, 2007

Share This Page