1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Please put my mind at ease

Discussion in 'Sony PSP - Mod and firmware discussion' started by charlywho, Mar 30, 2007.

  1. charlywho

    charlywho Member

    Joined:
    Mar 29, 2007
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    11
    I was using "DevHook 0.51 + Firmware 3.01" on my PSP and wanted to run the new DragonBall game. The game required firmware 3.03, so I did a google search and found "3.03 OE-C Winstaller.exe". The installation went fine, after an initial re-setup of the PSP, AND the game played.

    My initial confusions over what to use are however, now compounded with apprehensions. Can someone PLEASE PLEASE enlighten me and tell me that I have not screwed up my PSP.

    It seems that I am no longer using DevHook AND I have upgraded the PSP firmware from 1.5 to 3.03. I was not expecting this.

    Am I right in making these statements?

    Do I no longer need/use DevHook for now AND future games; what happens when the newer games require a higher firmware?

    Can I easily go back to firmware 1.5 using "1.50 Recovery Winstaller.exe" IF I wanted, when a new DevHook comes out OR if "Winstaller.exe" is not upgraded?

    And finally, have I applied the "right" firmware file? It seems that there are OE-A and OE-A' and 3.10 versions of the winstaller; what are the differences bewteen them and/or should I have used one of them?

    Please put my mind at ease; It's my boy's PSP.
     
  2. staxx

    staxx Regular member

    Joined:
    Nov 12, 2006
    Messages:
    817
    Likes Received:
    0
    Trophy Points:
    26
    Firstly, don't worry everything is fine.

    If your on 3.03 oe-c, no you do not need devhook because your already at a firmware that combines the features of 1.5 and 3.03 so it makes devhook obsolete since devhook was made to emulate the latest firmwares.

    Will it play all games released by sony? Well...when sony releases new games they usually require an updated firmware to play them. So to answer your question, no you cannot play the games that require 3.10 or 3.11 firmware.

    The difference between 3.03 oe-c and 3.10 oe a/a'. Well...If you like to customize your psp then i'd suggest staying at 3.03 oe-c mainly because 3.10 oe cannot have a customized topmenu_plugin.rco (custom icons). Other than that they are the same(feature wise).
     

Share This Page