1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PLS HELP ! i have psp 1002 ver. 1.5 but i cant update it in 2.0

Discussion in 'Sony PSP - Homebrew software' started by yap10, Feb 26, 2007.

  1. yap10

    yap10 Guest

    pls. help i cant update my psp 1002 1.5 to 2.0.. evrytime i try updating
    it says its applicable for my system.. T_T reply asap
     
  2. mrgooey

    mrgooey Regular member

    Joined:
    Nov 5, 2005
    Messages:
    4,058
    Likes Received:
    0
    Trophy Points:
    46
    what are u trying to update?
     

Share This Page