1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Plz help Iso.... ??

Discussion in 'Sony Handhelds' started by Datboya, Jun 5, 2007.

  1. Datboya

    Datboya Guest

    ok plzz i am desperate i am gonna downgrade my psp from 3.03 to 1.50 and here's the problem the switch that activatyes the laser in the umd case broke and my psp wont play UMD'S anymore if i ut iso''s on my psp will they still work withouth a disc or is there any homebrew that can help me thanks in advance!!
     
  2. CKhaleel

    CKhaleel Regular member

    Joined:
    Feb 26, 2007
    Messages:
    1,669
    Likes Received:
    0
    Trophy Points:
    46
    Srry man, but your screwed.
     
  3. Datboya

    Datboya Guest

    are u sure cant devhook help when am on 1.50
     
  4. mttp1990

    mttp1990 Member

    Joined:
    Jun 6, 2007
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    11
    look u can try do put the ISO in the games section of the memory stick and play it from there, btw, there is a shitload of isos at www.jasriel.com
     
  5. smlvfx

    smlvfx Regular member

    Joined:
    Dec 9, 2006
    Messages:
    1,358
    Likes Received:
    0
    Trophy Points:
    46

    if your psp can't read umd's then you can't downgrade
    to downgrade from 3.03 you need to use the gta liberty city original umd ,you need to load the game to activate 3.03 hen (homebrew enabler)
     

Share This Page