1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Premiere Elements 11 - Display slows and freezes

Discussion in 'Other video questions' started by redekin, Mar 31, 2013.

  1. redekin

    redekin Member

    Joined:
    Jan 1, 2013
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    11
    Program: PE 11, bought locally from a store in fall 2012 Computer: HP Pavilion p6-2109eo OS: Win 7 Home Premium 64-bit PE has worked wonderfully from its first day on my PC.

    Suddenly, when opening it, came the following information “We have detected an incompatible display driver. To get a better and faster playback performance, please update your display driver. Display driver details: ATI Technologies Inc. – AMD Radeon HD 6530D 3.0. 11476. Compatibility Profile Context.”

    I was quite content with the driver as it was! Now the PE gets slow and even freezes totally, and I have to force it shut down.

    Have then already executed a.o. following actions:
    a) Used CCleaner (I regularly and frequently do).
    b) Used HP Help to check my present display driver , and all seemed to be OK. Result: I seem to have driver AMD Radeon HD 7540 on my pc.

    Isn’t HD 7540 a more recent version than the above mentioned HD 6530D (which some loading sites mentioned as “old” etc!)
    c) Loaded , however, then AMD Radeon HD 6530D driver from some website. And installed it.
    d) Well, and uninstalled and then installed again PE. No changes in the problems.
    e) Installed then driver AMD Radeon HD 7540.
    f) Still "“We have detected an incompatible display driver. To get a better and faster playback performance, please update your display driver. Display driver details: ATI Technologies Inc. – AMD Radeon HD 6530D 3.0. 11476. Compatibility Profile Context.” - PE11 opens though, but slow and freezes. Had to force i to shut.

    Help appreciated, regards Reijo V. Alho
     
  2. rulisky

    rulisky Regular member

    Joined:
    Apr 26, 2006
    Messages:
    809
    Likes Received:
    0
    Trophy Points:
    26
    I understand that you said PE 11 has been working well before and now it is not. But have you checked the System Requirements for this program on the Adobe site? That would be my first thought.

    Second, what is new or different on your computer now versus before? Could be some conflict.

    Lastly, I would strongly recommend that you contact Adobe directly for help. They would know their product the best of anyone and could tell you what if anything is peculiar about your system re. their product.

    Good luck!
     

Share This Page