1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problems with Leadtek Winfast TV USB II

Discussion in 'Video capturing from analog sources' started by herbie13, Aug 15, 2004.

  1. herbie13

    herbie13 Member

    Joined:
    Aug 15, 2004
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    11
    I've been having major problems with the Leadtek Winfast TV USB II

    1st problem even though i have USB2 ports and Windows SP1 installed my Leadtek Winfast TV USB II refuses to acknolege that the usb2 is a high speed connection, even took off the drivers and software and re-installed them after updating to SP1 still refuses to acknolege a high speed device link via USB

    2nd problem is that i get very poor capture quality using Leadtek Winfast TV USB II seems to me that if i play the video through a normal tv the qaulitys good on the recording on the VHS tape as its recorded from Cable TV, however when i try to capture from the CHS tape to my capture card Leadtek Winfast TV USB II using WinPVR i get very poor quality capture. I've tried everything to improve the capture to no avail still get poor quality catpure blocky with line from top to bottom of the screen can see pic ok but it looks a bit awfull played back at full screen. However when i play it though an mpeg player still get the blockyness of the capture.

    If anyone else has come accross these problems and has been able to fix them, please let me know as im at a loss of how to improve the capture. At the moment the Leadtek Winfast TV USB II is on the fast road to being a useless doorstop if i cant improve capture
     
  2. Minion

    Minion Senior member

    Joined:
    Sep 28, 2003
    Messages:
    5,768
    Likes Received:
    0
    Trophy Points:
    116
    Have you gone to your Device manager and right clicked on the USB controller and go to "Update Driver" Cuz the USB 2 Driver is Not Installed By Default....

    Generally USB Capture Device Suck Pretty Bad, to get a Really good one you mught have to spend up to $450....

    If the Device only thinks you have USB 1.1 then it will only Capture at the Lowest resolution and Quality Possible so when you resize it to full screen you will get a Very Blocky Image...

    Also are you sure your USB Ports are USB 2.0 because the actual Ports for USB 1.1 and USB 2.0 are different...USB 2.0 can work as USB 1.1 but even with the Correct usb 2.0 drivers Installed a USB 1.1 port will allways be a USB 1.1 port....

    If you Know the Ports are USB 2.0 and Have SP1 installed you still have to go to the Device Manager and Update the Driver for the Port before it is USB 2.0...

    Cheers
     

Share This Page