1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PS1 on PSP Advice needed!

Discussion in 'Sony PSP - Mod and firmware discussion' started by jin666, May 31, 2007.

  1. jin666

    jin666 Regular member

    Joined:
    Jul 1, 2005
    Messages:
    767
    Likes Received:
    0
    Trophy Points:
    26
    Hey guys,

    Haven't been on in a long time. Had exams but thankfully there all over now :D.

    Due to being off the scene for such a while, I'm pretty outdated on the whole PSP stuff. Although I recently purchased MGS:portable Ops which I love.

    Anyway, I have a few questions. I am from a PAL region. I feel it is important I point that out. My current PSP firmware is 3.03.

    I am looking to put my original and backup PS1 games onto the PSP for use. Note that the PS1 games I will be using are all PAL. Is it possible for me to put these games onto the PSP and play them?

    I realise there are guides out there but they seem to be focused on NTSC and I am afraid of compatibility issues which may cause me to brick my PSP :(.

    Note: If I am able to do this, I will invest in a 2GB card to replace my current 32MB. If not, I see no point in purchasing a new card.

    Please help out guys,

    Jin666
     
  2. MetalGeat

    MetalGeat Regular member

    Joined:
    Mar 12, 2007
    Messages:
    616
    Likes Received:
    0
    Trophy Points:
    26
    Well the region shoudln't matter for downgrading because you need gat l.c.s upatched so just just a pal version of the game. and downgrade to 1.5. The region wouldnt make a difference in homebrew.
     
  3. chanman1

    chanman1 Regular member

    Joined:
    Feb 6, 2006
    Messages:
    1,705
    Likes Received:
    0
    Trophy Points:
    46
    And seriously, stop being scared about bricking...the only time you will brick is with messing with flash, like downgrading, etc
     
  4. jin666

    jin666 Regular member

    Joined:
    Jul 1, 2005
    Messages:
    767
    Likes Received:
    0
    Trophy Points:
    26
    Right guys cheers for the replies. Well I checked my LCS game which I have and its got the upgrade for 2.00 on it (where I read somewhere was required.) Right, I'm not exactly sure what I need to do, because apparently I need to downgrade to 1.5 and then back up to a custom firmware or something? I'm going to check the other forums on it but please keep the information coming in here!

    Also, can someone confirm how well the PS1 games play (everything is PAL).
     
  5. chanman1

    chanman1 Regular member

    Joined:
    Feb 6, 2006
    Messages:
    1,705
    Likes Received:
    0
    Trophy Points:
    46
    find a downgrader guide for 3.03 and downgrade then
     

Share This Page