1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Ps2 not powering problem

Discussion in 'PS2' started by trevor07, Jan 18, 2007.

  1. trevor07

    trevor07 Member

    Joined:
    Dec 25, 2006
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    11
    I just got a ps2 for free and when i plug it in and flip the switch the red light will come on but then when i hit the power button it will not turn green and come on it just sits there with the red light on can anyone diagnois this for me?

    Only thing the ps2 is missing is the fan not sure if that is keeping it from powering.

    Im waiting on a replacement for it for now.
     
  2. trevor07

    trevor07 Member

    Joined:
    Dec 25, 2006
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    11
    guess ill look elsewhere for help
     
  3. Fil2065

    Fil2065 Guest

    I dont know shit about this problem, but from what you have said its a possablity that the switch isnt working. Im assuming the case has been taken off in the past as you are missing your fan. When it was re-attached it is possable that the switch and the button havnt been aligned correctly. Meaning that if you push the button its not doing anything to the switch.

    I dont know anything about the fan side of things, but ive herd of people running there PS2 with fans that dont work, so i assume you can turn on a PS2 without a fan.

    Suss out the button and switch to make sure the button is aligned.
     
  4. Bruce_34

    Bruce_34 Member

    Joined:
    Jan 23, 2006
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    11
    I had a problem similar to this with one of my fat ps2's and I just bought a replacement switch and ribbon from Rich's Psx Parts for like $9.95 and that solved all my problems
     
  5. NHS2008

    NHS2008 Regular member

    Joined:
    Dec 14, 2006
    Messages:
    626
    Likes Received:
    0
    Trophy Points:
    26
  6. vicious10

    vicious10 Member

    Joined:
    Jan 7, 2007
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    11
    Well Trevor, i have had this problem as well... if it is missing the fan it was clearly taken apart before so probably some idiot put a screw threw the ribbon cable, if you want just open it take a look. and as for a fan... you probably want to pick one of those up too :p
     

Share This Page