1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PSP 1.50

Discussion in 'Sony PSP - Mod and firmware discussion' started by maca1, Jul 12, 2007.

  1. maca1

    maca1 Regular member

    Joined:
    Mar 15, 2006
    Messages:
    630
    Likes Received:
    0
    Trophy Points:
    26
    Hello. I have a 1.50 PSP and I have a few questions.

    1. Do you need to have the latest PSP firmware to play the latest PSP games that you can buy in shops? I mean, if I went out and bought a game, would there be a chance it wouldn't work on my PSP

    2. If I update to Dark Alex's 3.40 OE, will I ever be able to update to Sony's latest firmwares?
     
  2. CKhaleel

    CKhaleel Regular member

    Joined:
    Feb 26, 2007
    Messages:
    1,669
    Likes Received:
    0
    Trophy Points:
    46
    1. Yes

    2. No.
     
  3. maca1

    maca1 Regular member

    Joined:
    Mar 15, 2006
    Messages:
    630
    Likes Received:
    0
    Trophy Points:
    26
    Well that just sucks. What about the people who go out and buy games not knowing about firmwares...
     

Share This Page