1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PSP 2.6

Discussion in 'Sony PSP - Mod and firmware discussion' started by wire73, May 11, 2007.

  1. wire73

    wire73 Member

    Joined:
    Nov 5, 2005
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    11
    I have a psp version 2.6.I intend to downgrade to 1.5 though I havnt got the unpatched version GTA liberty cities.Will it be possible for me to upgrade to 2.71 for eg and than downgrade from there.As 2.71 dont req the game GTA?
     
  2. shadow270

    shadow270 Guest

    yes,its possible to downgrade from 2.71 or 2.80 without a gta lcs unpatched UMD.
     
  3. wire73

    wire73 Member

    Joined:
    Nov 5, 2005
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    11
  4. wire73

    wire73 Member

    Joined:
    Nov 5, 2005
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    11
    no problems now.I downloaded the usa firmware 2.71It was a jap version that caused the corupted data.Also I've done the upgrade to 2.71 than when up to 3.10 0ea.All is working well.
     

Share This Page